Support Community
Showing results for 
Search instead for 
Do you mean 
Reply
Analyst Nation Moderator
Posts: 5,895
Registered: ‎11-25-2013

Re: Workcentre 5330 Email Error (017-714)

Thank you for coming back to respond.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
Valued Advisor
Posts: 1,688
Registered: ‎10-11-2010

Re: Workcentre 5330 Email Error (017-714)

some more info : 

 

The products affected by this issue are, WC 7120/25, WC 74xx, WC52xx, and XC 550/560/570. All of these devices are out of production. Their replacements all support SHA256 and 2Kcertificates.

 


If you have a network trace of the failure you can see if the certificate is signed with sha256.

In Wireshark open the trace file.

 

Type tcp.port==xxxx into the display filter dialog box and click "Apply" (Where xxxx is the port the device is using for SMTP).

 

Approximately ten lines down in the top window you will see a line that has "Certificate" in the info field. Highlight this line and expand the first entry for "Secure Sockets Layer" in the middle window.

 

Continue to expand the Subtrees until you open one called "Certificates".

 

Now you will need to find the certificate that is being used for SMTP, usually it will have "smtp" somewhere in the "id-at-commonName="

 

Expand that certificate and look for the line that says "algorithmIdentifier" if it says "sha256WithRSAEncryption" next to it you will have a problem. Most devices with DMP controllers do not support this signature and the email will fail with a 017-714 error.

 

New Member
Posts: 4
Registered: ‎02-02-2017

Re: Workcentre 5330 Email Error (017-714)

I've solved my Gmail error (017-714) installing the firmware (53.32.93) linked some posts ago... (thanks a lot!)

 

Now i've seen that there is a new recent fw (v. 53.33.32) for 5335... This is the last one? Where can i find a changelog?

 

I'm sorry, but why i can't find this version in my localized support page?

Analyst Nation Moderator
Posts: 5,895
Registered: ‎11-25-2013

Re: Workcentre 5330 Email Error (017-714)

Yes, 53.33.32 is the latest One-Off.

 

It's only purpose is this:

  • Xerox 5330/5335 MFD’s will now support a password length of 4-32 characters.
    Ability to have 15 character or greater is necessary to comply with DOD STIG security standards

This one is English only, you cannot run it in any other language, it was developed for a particular location and is not available on Xerox.com

 

Then there are what you have running, they are spar firmwares, they are not indexed on Xerox.com and never will be, the latest version publicly available for all machines are the latest General release, they go through vast amounts of testing and are the only ones listed and indexed,  spars are built off of them, but do not go through the full testing, they go through tests that should be affected by the fixes within. So while it isn't considered beta software, it is not RTM either.

 

So spars are available on Xerox.com, and just not indexed, so they can't be cross-referenced or found by a search engine. So if you have the link to one, always keep it, because it goes to the latest version only, so when a new one comes out, it has the same link as the last one, so when this machine gets a new firmware, it should be at the link I supplied previously. We do not keep multiple versions online.

 

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
Account Deactivated
Posts: 4
Registered: ‎12-15-2017

Re: Workcentre 5330 Email Error (017-714)

[ Edited ]

I have found after working with Xerox level 2 support that the printers that have the option for STARTTLS will work with G-Suite if the setting for Less Secure Apps is set to allow
Once this is allowed then the SMTP.GMAIL.COM server can be used on port 587 with SMTP AUTH on STARTTLS encryption protocol. Hope this helps a few people

Xerox Scan to Email G-Suite.png

New Member
Posts: 1
Registered: ‎01-04-2018

Re: Workcentre 5330 Email Error (017-714)

[ Edited ]

Hello!
Is it possible to install firmware for the 5325/5330/5335 to the 7120 one?

Software System    Version 71.13.41 right now, and Im having problems with Scanning to gmail. I've tried already different combinations of smtp server and auth - with no success.

Or can somebody tell me, where I can find the newer firmware for xerox 7120 please? Sadly, that Xerox doest not have every firmware listed on their web.

 

 

UPDATE: yay, found it! 71.24.12 (link) - and everything is working fine! :) although, 71.21.21 - had not helped too.