Showing results for 
Search instead for 
Do you mean 
New Member
Posts: 3
Registered: ‎10-27-2014

WorkCentre 5150 Firmware update fails

I have two WorkCentre 5150s, both initially running firmware v021.120.052.000.  


I am trying to update to the latest SPAR release I could find, v021.120.065.270, to address issues scanning via SMB (w/out NetBIOS) to a new Server 2012 box. 


The first device updated via CWIS without a problem.  The second device begins the software upgrade, displays the various progress bars on the device control panel, but restarts after 3-5 minutes and boots normally to the old firmware without continuing the update.  I have tried initiating the update via CWIS multiple times now with the same result. 


This is not a single-board controller 5150, so as far as I know CWIS is the only option I have to update (no USB Flash Drive update).  


Any assistance would be greatly appreciated.



Russ D.

Analyst Nation Moderator
Posts: 4,921
Registered: ‎11-25-2013

Re: WorkCentre 5150 Firmware update fails

The 5150 is Altboot capable, so if you know how, do that (Settings will be lost though)


It is against Xerox rules to post how an Altboot is done, but it can be found via Google. (Just can't be posted here on the forum)

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!