Support Community
Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 3
Registered: ‎10-21-2016

WorkCentre 6605DN - problem with Linux Driver

Hi,

 

I'm using WorkCentre 6605DN at the office wiht my PC with installed Fedora Linux 25. I installed  xeroxprtdrv 5.20.558.3113 and launched xeroxprtmgr us root. The Wizard found the printer but "Internal error, check the log" message appeared. I checked the logs and i found:

 

21:05:05 - Quemgr:  Request for legacy PPD model identifier - has been deprecated in favor of model OID
21:05:10 - ERROR/OSInterface:  SysCmd() - Command failed: /usr/sbin/lpadmin -p_xeroxtq1_ -E -i/opt/Xerox/prtsys/XeroxXSF 1>>/tmp/OSICmd.log 2>>/tmp/OSICmd.log
lpadmin: Unable to open PPD "/opt/Xerox/prtsys/XeroxXSF": Missing asterisk in column 1 on line 1.
lpadmin: Bad PPD file.

 

Searching about that problem i found that thread with the same problem like mine, but i could not use the solution there. There is not a generic ppd files for WC 6605DN.

 

 http://forum.support.xerox.com/t5/General-Information/can-t-install-workcentre-7830-printer-on-debia...

 

I tried also with Linux Intel Driver (x64) but without success.

 

 

 

Analyst Nation Moderator
Posts: 5,898
Registered: ‎11-25-2013

Re: WorkCentre 6605DN - problem with Linux Driver

"Searching about that problem i found that thread with the same problem like mine, but i could not use the solution there. There is not a generic ppd files for WC 6605DN.

 

 http://forum.support.xerox.com/t5/General-Information/can-t-install-workcentre-7830-printer-on-debia..."

 

 

Yes there is. And just like the other, it's contained in an executable, so you need to extract it first as stated in the referenced post

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
New Member
Posts: 3
Registered: ‎10-21-2016

Re: WorkCentre 6605DN - problem with Linux Driver

Thank You so much for the quick reply!

 

I downloaded and extracted the ppd files, but now I got that message:

 

Screenshot from 2016-10-21 22-34-14.png

Analyst Nation Moderator
Posts: 5,898
Registered: ‎11-25-2013

Re: WorkCentre 6605DN - problem with Linux Driver

Try changing the CRLF to LF then.

 

There are many ways to do so

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
New Member
Posts: 3
Registered: ‎10-21-2016

Re: WorkCentre 6605DN - problem with Linux Driver

I manage to get in working today. "changing the CRLF to LF " is only a warning when parsing the ppd. The error was at the ppd: The line  "*CloseGroup: PaperOutput" shoud be moved before the line "*OpenGroup: PrintQuality/Print Quality/Color". This is what the error is reporting. I'm thinkig that this kind bug repors will growing because of the new CUPS 2.2.x version. With Fedora 24 and XeroxPrtDrv there was no problems. Every Linux Distribution shiping with the new CUPS will be problematic for the Xerox customers. Please Xerox, kindly asking for testing and upgrade the linux drivers due to that. Thank you very much.

 

Screenshot from 2016-10-21 22-34-14.png

 

Analyst Nation Moderator
Posts: 5,898
Registered: ‎11-25-2013

Re: WorkCentre 6605DN - problem with Linux Driver

This forum is peer to peer, to get Xerox engineerings ear you need to call Xerox and report the issue.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
New Member
Posts: 3
Registered: ‎12-20-2017

Re: WorkCentre 6605DN - problem with Linux Driver

As this is the first topic that cames out in google, i'll post to this thread.

I had exactly the same problem, and finally I managed to solve it, using the xerox driver that gives you some extra functionality: ppd itslef claims to support stapling, but the printer ignores the settings.

 

If you want to use the driver use the following steps. They require in some part root access, be careful.

1- Install the driver package, in my case I use ubuntu one. It will create a bunch of files in /opt/Xerox/prtsys

2- navigate to that directory: cd /opt/Xerox/prtsys

3- as root, copy the file XeroxQScript in /usr/lib/share/cups/filters:  sudo cp XeroxQScript /usr/lib/share/cups/filters

4- replace XeroxQScript with a dummy ppd file containing the following 4 lines

*PPD-Adobe: "4.3"

*cupsFilter: "application/postscript 0 /usr/lib/cups/filter/XeroxQScript"
*cupsFilter: "application/pdf 0 /usr/lib/cups/filter/XeroxQScript"

 

5- replace XeroxXSF with a dummy ppd file containing:

*PPD-Adobe: "4.3"

 

*cupsFilter: "text/plain 0 -"

 

6- Run as root xeroxprtmgr and add the printer!

 

Best,

Leonardo

Highlighted
New Member
Posts: 3
Registered: ‎12-20-2017

Re: WorkCentre 6605DN - problem with Linux Driver

[ Edited ]

Update on my previous post... I hadded one more print and it didn't manage to have a good install.

After completing the steps above, connect to cups interface (localhost:631),; you'll find two printers, one is the xerox printer and the other printer may appear as "bad ppd". Just update it, and change to a "raw printer" (also check if the connection is ok)

Leo