Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 2
Registered: ‎09-08-2017

6510 LCD Message - Check PrimaryNet

I just setup my first 6510dn.  I'm using USB and no network connections.  Everything seems to work fine.  However, under "Ready" on the LCD screen it says, "Check PrimaryNet".  I'm guessing that is because I'm not using any network connection?  Is there a way to turn off that message or does it mean something else?

 

Thanks,

 

Jamie

Community Manager
Posts: 2,574
Registered: ‎07-21-2010

Re: 6510 LCD Message - Check PrimaryNet

Hi jedwards,

Thank you for using the Support Forum. Please make sure that you have followed the instructions for setting up the printer to print over USB.  If you have followed all these instructions and you continue to get the error please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

New Member
Posts: 2
Registered: ‎09-08-2017

Re: 6510 LCD Message - Check PrimaryNet

Thank you for the response.

 

I ended up connecting the printer to the network for other reasons, which of course got rid of the error.

 

Just a note...I downloaded the drivers from the web and didn't use the included CD.  Maybe using the CD first is the key.

 

Jamie 

New Member
Posts: 2
Registered: ‎01-06-2018

Re: 6510 LCD Message - Check PrimaryNet

I also have this issue, i connected this 6510dn with usb to my imac, the message Ready. Primair network check. (translated from Dutch) is always on the display.

I also can never find where I can check the toner levels, it's nowhere to find in the printer menu and the software on my mac says when i klick on 'status' no information available.

 

I really don't no what to do with this.

Marco

Highlighted
New Member
Posts: 2
Registered: ‎01-06-2018

Re: 6510 LCD Message - Check PrimaryNet

ok, I was a little too fast with my replay.. I found another post which gave me the solution which works! I also have the toner levels in the display now.

Thx for this solution.

 

Log on as admin and go to

Menu > Admin Menu > Network Port > TCP/IP Settings > Ethernet > Get IP Address > Static > IP Address

 

Since you don't have it on the network, the settings don't matter beyond needing to look real, so 10.10.10.10 can be the IP qand the gateway. 255.255.255.0 would be fine for the subnet mask

 

gr

Marco