Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 2
Registered: 3 weeks ago

Invalid Toner Phaser 6600 with new Genuine toner

Hi,

 

I just bought Genuine toner for Phaser 6600 / 6605 and when i installed it , first i have toners status and then message  : " Invalid Yellow".

 

I read that toners have to be from the same region like old one . i checked it and both are made in Japan .

 

Is there any way to fix that or toner is faulty ? 

 

Thank you for any suggestions .

Analyst Nation Moderator
Posts: 4,761
Registered: ‎11-25-2013

Re: Invalid Toner Phaser 6600 with new Genuine toner

Where it is made doesn't change, where it is for does. All is held in a chip on the toner.

 

There is no difference beyond the chip that is in it.

 

There is no big conspiracy, the only reason there are regions is because of countries/areas that have things like the VAT that make things cost more than they do in areas near them, it puts an end to cross border shopping as it were.(There was a time not too far back where it was cheaper for an Australian to fly to the USA, buy Adobe creative suite, then fly home, for cheaper than buying Creative suite in Australia)

 

Sold vs metered is just so that Xerox knows if you used a 3rd party toner, or if you are trying to claim that a device that is not on contract has one. I'm sure the marketing types have some fabulous reasons too.

 

It does occasionally really make things difficult for the end user, but, it is what it is.

 

It is not just Xerox, that doesn't make it better of course, but it isn't just Xerox

 

Assuming you have the right one for your printer (metered vs sold) and from the right area (North America, DMO, Asia Pacific) then it would be defective.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
New Member
Posts: 2
Registered: 3 weeks ago

Re: Invalid Toner Phaser 6600 with new Genuine toner

Thank you for reply. 

 

I just get new genuine toner from xerox and i have same error message .... 

 

INVALID YELLOW

 

Do you have some other solution for that ? 

Is there any manual how to clean this model . maybe i need to clean some place ( chip , etc ) 

 

Thank you for any reply