Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 1
Registered: ‎10-27-2017

VersaLink B405 not registering with Google Cloud Print

VersaLink B405, Software version: 38.10.91

 

I cannot get this printer to register with Google Cloud print. I have a Xerox Altalink and Epson printers on the same network that easily register to Google Cloud print, so I don't believe it's a network issue. Steps I have tried so far,

 
  • Checked date and time, even setup time server.
  • I have tried turning on and off "https"
  • I have turned on IPv4 only and both IPv4 and IPv6 at the same time.
  • I have tried changing the DNS servers to 8.8.8.8 and 8.8.4.4 to no avail.
  • I have logged in as "admin" and tried it without being logged in as admin.
  • I have rebooted the device many, many times, as each time you change a setting it requires a reboot.
  • Proxy on and off, mostly off.
  • CSRF Protection on and off, mostly off.
  • The printer has never registered, so it's not an issue of it being "offline" in Google Cloud Print.
  • I've probably tried many other things, but can't think of them all right now..
Here's the process so far. With Google Cloud Print enabled, I select "Register". It goes to a black screen with a message that it's printing documents on how to setup Google Cloud Print. Sometimes it just does this for a few minutes before going back to the "Register" screen. Sometimes it shows an error, but it never prints anything, even though the Audit logs say it printed something from Google Cloud Print.
 
Typically when setting up Google Cloud Print, a new screen will pop-up asking me to log into my Google account to register the printer. Is some sort of screen supposed to be popping up? It keeps saying it's printing instructions, what do these instructions say to do? Do the instructions have a code or an alternative method to register the printer? If so, is there a way to replicate these instructions? It would be incredibly helpful to watch a video of someone registering one of these printers with Google Cloud Print so I at least know what it is that's supposed to happen. The instructions are incredibly vague in the manual.
 
I bought 2 of these printers solely based on their advertised ability to work with Google Cloud Print, and I would like to buy more but this is an absolute show stopper. Any suggestions?
Highlighted
Analyst Nation Moderator
Posts: 5,229
Registered: ‎11-25-2013

Re: VersaLink B405 not registering with Google Cloud Print

Try a firmware update

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.