Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 1
Registered: ‎03-14-2017

colorQube 8580 error 99,070

 

Our xerox colorQube will not start up, when turning on it goes through the initial power on self test ok and the xerox logo scrolls on to the screen and then.... nothing. just sits at the logo. Left it for over an hour, no response to any button pressing or etc.

 

If you turn it off with the power switch then after a while the logo clears, the display briefly shows '1% initialising' then it goes to 'Printer Error: 99,070.00:941' before it turns itself off

 

gone through the process a few times and it is consistent

 

is there any hope for it?

Community Manager
Posts: 2,355
Registered: ‎07-21-2010

Re: colorQube 8580 error 99,070

Hi mfretwell,

Thank you for using the Support Forum. Please turn the machine off and disconnect any cables attached to the machine (network, usb, etc.) WIth the cables disconnected power the machine back on.  If it starts up without the cables, plug them back in after it turns on and see if it will work.  Also check your power source. Make sure the power cord is plugged into a dedicated outlet with no power strip or surge protector to see if that might be the problem.  If none of this helps please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!