Showing results for 
Search instead for 
Do you mean 
Reply
New Member
Posts: 1
Registered: ‎08-18-2017

Card Reader Sending Incorrect Values

I am trying to get a new Altalink B8055 set up to authenticate RFID cards with PaperCut... Everything seems to be configured correctly to communicate with the PaperCut application on the server, however the problem I am having is that whenever I swipe a card at the machine it doesn't read the value that is on the card, and instead comes through with some unknown jibberish code.

 

For example, our RFID cards each have a 5 digit value assigned to them (e.g. 12345).. But when the machine reads it, an 8-character value is returned (as both letters & numbers... e.g. 12AB3C4D)

 

Is there a setting that needs to be changed in order for the cards to be read properly? I am using the integrated RFID card reader that came with the machines... There doesn't seem to be any settings in the web interface that allow me to alter it in any way.

 

Help would be appreciated, thank you.

Analyst Nation Moderator
Posts: 5,225
Registered: ‎11-25-2013

Re: Card Reader Sending Incorrect Values

Card readers support specific cards, not all cards, you need to make sure they are compatable

 

Compatablity

 

RFID Reader (497K18650)

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
Valued Advisor
Posts: 1,645
Registered: ‎10-11-2010

Re: Card Reader Sending Incorrect Values

are you using elatec TWN4  or TWN3 readers? , those readers are reading in default HEX format

with TWN 4 its easy to change with the TWN4 blaster tool, with TWN3 you need to compile a new script and upload it to the reader , both tools can be downloaded on elatec website

 

if its as easy as converting from hex to dec, you can check and test it with your calculator, then in papercut, device, advanced config, you can input hex2dec on the correct line attribute