Showing results for 
Search instead for 
Do you mean 
New Member
Posts: 3
Registered: ‎03-08-2017
Accepted Solution

Workcentre 7855 Accounting + Linux = Problems

[ Edited ]


So, let me preface this by saying I've read how Xerox software is not compatible with CUPS now, which lead me down the path to extra the ppd file from Windows. I used this as a guide to modify the ppd for accounting purposes:


We have XSA enabled at the school where I work, and I have complete access to the printer in terms of admin passwords. My issues is that when I follow the above instructions, I continually receive accounting errors indicatng invalid accounting codes.


Is there an update version of the above link somewhere that I am missing? I noticed the updated Workcentre software published in February, but that did not install correctly on Linux Mint (which is Ubuntu and Debian-based).


Any information would be very appreciated!

Analyst Nation Moderator
Posts: 5,461
Registered: ‎11-25-2013

Re: Workcentre 7855 Accounting + Linux = Problems

I followed that document with XSA on the 7855 today on Ubuntu 16.04 and it worked, if there is an issue with Mint, you may need to call Xerox 2nd level.



Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

New Member
Posts: 3
Registered: ‎03-08-2017

Re: Workcentre 7855 Accounting + Linux = Problems

Thanks for responding, Joe!


There's not too much difference between Linux Mint and Ubuntu from what I understand and have experienced. The menu in the XFCE version is exactly the same in Xubuntu with system-printer-config.


Admittedly, kind of a newbie with this. Is there any location within the ppd that I should copy and paste the General Accounting code?


Since we track everyone per user ID and use the standard 999999 for the group, I'm spitballing and thinking the above might be the only problem I have.


If you could provide an example of how you modified your ppd,  that would be a great help!



New Member
Posts: 3
Registered: ‎03-08-2017

Re: Workcentre 7855 Accounting + Linux = Problems

Nevermind. I found out that one needs to put the XSA code between these two lines:

*JCLEnd:"<1B>%-12345X@PJL EOJ<0A><1B>%-12345X<0A>"

 I'm writing something up just in case someone else has this issue.

New Member
Posts: 1
Registered: ‎06-08-2017

Re: Workcentre 7855 Accounting + Linux = Problems



Having the same issue with Ubuntu 16 and Xerox 7556, Do you have an example on how the line with accounting code looks?


Have found a few other examples via google and even the doc in this post but none ot them worked