Showing results for 
Search instead for 
Do you mean 
Reply
Member
Posts: 16
Registered: ‎07-25-2016

App Gallery Apps will not install - Device update required

I have a Xerox 8900X.   I am trying to install Apps like print Scan to Google Drive, and Box.   Also Scan to Cloud email app.

 

I get this error message

"This app requires a software upgrade on your device. For a list of supported devices and software versions, please refer to the compatible products atwww.office.xerox.com/connectkey/apps or contact your Xerox equipment Supplier"

 

My device software appears to be the latest version at 072.162.004.09100

 

Please help

Analyst Nation Moderator
Posts: 4,017
Registered: ‎11-25-2013

Re: App Gallery Apps will not install - Device update required

I linked you the firmware already in your older post here.

Please install it and then post an update with the results.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
Member
Posts: 16
Registered: ‎07-25-2016

Re: App Gallery Apps will not install - Device update required

Joe,

 

Thanks for the link.   I performed the update.   That was successful.  My system software is now 072.161.206.11200

 

However, The apps in the App Gallery will not install.   Most give me an the same error.

 

 

"This app requires a software upgrade on your device. For a list of supported devices and software versions, please refer to the compatible products atwww.office.xerox.com/connectkey/apps or contact your Xerox equipment Supplier"

 

I deleted the 8900X from the App Gallery and re added it.   Still no luck.   Some Apps give an error of, like the print and scan from google, of 500-internal server error.

 

Please help

Highlighted
Moderator
Posts: 55
Registered: ‎03-04-2016

Re: App Gallery Apps will not install - Device update required

Hello. 

 

The Apps. should work if the device has a compatible EIP version installed.  The version that you have indicated is installed should have a compatible EIP version.  

 

I recall one other case where a similar device did not properly report the EIP version and as a result could not install the apps.  This sounds like it may be the same issue.  This previous case was resolved by completing an ALT-BOOT on the device.

 

You could give that a try.  If an ALT-BOOT resolves the issue, please let us know. 

 

Thanks!