Support Community
Showing results for 
Search instead for 
Do you mean 
Reply
abc New Member
New Member
Posts: 3
Registered: ‎03-14-2018

install xerox app gallery

Hi

 

I am trying to install Xerox app gallery on workcentre 3655. Getting following errorerror.PNG

 

Please help

Xerox Employee
Posts: 289
Registered: ‎05-10-2013

Re: install xerox app gallery

Hello. 

 

Check that the SNMP options are set properly using the Centreware Web for the device.

 

Here are the steps to check this setting: 

Launch the device CWIS page (type the device IP address into a browser window). 

Log into CWIS using the device Admin credentials. 

Select the Properties tab. 

Select the Connectivity option from the menu on the left side of the screen. 

Find the SNMP entry and click the Edit link to the right. 

Make sure that only the first two options are checked:  Enable SNMP v1/v2c Protocols and Allow SNMP v1/v2c Set 

Save the changes and close the CWIS page. 

Go back to the App Gallery (appgallery.external.xerox.com) and retry your app install.  It should now work.   If it does not, please let me know and I'll investigate. 

 

Thanks, 
XAS Moderator

Xerox Employee
Posts: 289
Registered: ‎05-10-2013

Re: install xerox app gallery

Hello. 

 

One additional bit of information.  The SNMP value is case sensitive.  The default value is 'private'.  Note the lowecase 'p'.  If 'Private' is used when adding the device to App Gallery, the SOAP-ENV message that you exerienced will display. 

 

I just wanted to share this as one more item to check. 

Thanks, 

XAS Moderator

abc New Member
New Member
Posts: 3
Registered: ‎03-14-2018

Re: install xerox app gallery

Capture.PNGHi Thanks for your response. I was able to install Xerox app gallery. But getting following error after installation;

Xerox Employee
Posts: 289
Registered: ‎05-10-2013

Re: install xerox app gallery

Hello. 

 

The SOAP error that you have captured will occur when the device is using a SNMP Community String that is not the default setting.  The App Gallery App is currently not compatible with customer community string settings.  This is a known issue and there is a defect in the system that will be address in a future release.  We will post release announcements on this forum, so please check back here for updates. 

 

My apologies for any inconvenience. 

Thank you, 

XAS Moderator