cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

7830 NO EMAIL !!!!! (login error)

Hi,

 

desperately trying to get my 7830 to send emails...  test always returns a login failure !!

 

configured user & pwd, server name, port is default 587, connection encryption set to STARTTLS, I tried server by name, and by IP to exclude DNS issues...

 

The exact same settings work flawlessly with ANY mail client... 

 

I'd use network traces to debug this if I could, but I'm a freelance, this is my home MFD, and I've got no switch with span ports on my home network...

 

How the hell can I debug this ?????  Where could I find some more detailed info than 'Login Failure' ???

I tried to download the network logs, but these seem to be encrypted, and I found no way to read them (yet...), and I don't know if these would be helpful, either...

 

I know email problems have been addressed in many posts, but none match my problem... eveything seems perfectly fine at config level...

Is there anywhere something that would prevent SSL/TLS from working correctly ?? (in HTTP I forced HTTPS on 443 and use the device's default certificate, the web interface works fine with that)

 

If I disable SMTP connection encryption, I get exactly the same error, so I'm not sure at all what the message really means...

 

Thanks in advance

 

 

 

0 Kudos
3 Replies
Highlighted

Re: 7830 NO EMAIL !!!!! (login error)

 

Software is 073.010.075.34540

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: 7830 NO EMAIL !!!!! (login error)

First, upgrade your firmware with the latest release from here.

 

Once you have done that, we can safely assume that the machine is capable of whatever encryption is in use by your mail server.

 

Authentication errors have many causes, so I am just going to break this down step by step, and we will get rid of the dumb stuff first, do not skip the dumb stuff, do it all or you will just be wasting time, I wouldn't bother typing it out and screenshotting it if it could be skipped.

 

CWIS > Properties > General Setup > Date and time. This has to be less than 3 minutes off, so change it if it is off by even a little, this one is a big pain because it forces you to reboot the device, but everything relies on this so we do it first. Set it to Manual, or NTP, all up to you.

 

6.GIF

 

When it comes back online go to CWIS > Properties > Connectivity > Setup and Edit the active connection.

 

1.GIF

 

Select Edit on the IP field

 

2.GIF

 

Expand the DNS subsection and make it right, toss 8.8.8.8 in there as the primary just so we know at least one entry is correct.

 

4.GIF

 

Now, verify the connection to the outside world via CWIS > Properties > General Setup > Smart eSolutions setup > Test Communication now

 

5.GIF

 

If it fails, look to your Gateway address, or your Proxy server because everything else is covered at this point. If it is good you will get this:

 

7.GIF

 

So now we know there is nothing stopping it from getting to the mail server. And since the firmware is up to date there will be no SHA-2 problems with Office365 or Gmail etc.

 

Since I don't know your mail server info, I am going to pretend Office365 for convenience.

CWIS > Properties > Connectivity > Setup > SMTP (Email) > Edit

 

 smtp.office365.com port 587, using STARTTLS (Do not choose "STARTTLS if available"). Make sure the login name and from address are identical. Also make sure both logins are set to System before you type them in.

 

 11.gif

 

12.gif

 

13.gif

 Then go to CWIS > Properties > Services > Email > Setup and edit the From Field entry. This one is possibly your issue, the from address gets populated when you setup SMTP the first time, but when you modify SMTP it does not get updated here, so you get a login error since you are using 2 different accounts. Like logging in as me@mine.com, but trying to send from me@yours.com, thus, a login error. In short, the email address is in 3 places, they have to match.

 

14.gif

 

 
 

17.gif

 

 

 

 

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos
Highlighted

Re: 7830 NO EMAIL !!!!! (login error)

 

thanks for all the info, in fact I got it relatively easily to work with gmail, and meanwhile also with others, but NOT with OVH, where my exchange account is hosted...  and I'd like to avoid using Gmail & Co for professional mails...  so not really happy with the current setup...

 

I'll get my hands on a switch with a span port next week, so I'll be able to see what passes over the line (Wireshark & Co) and eventually find out why my 7830 and OVH refuse to collaborate...??? OVH support have helped as far as they could, but that doesn't go beyond setup...

 

I'll post my findings asap.

 

0 Kudos