Showing results for 
Search instead for 
Did you mean: 
2 Replies

Re: AltaLink C8155 and B8155 Stuck on DST

Thank you for your reply.

I did end up resorting to Technical Support, which I was escalated from chat support to Level 1, then to Level 2, then to Level 3, and they were able to replicate the issue, but none of them could have solved the issue. I did not want to manually set time as the precision of the clocks on Xerox machines is not that great, but apparently, that's the only solution unless they come up with new firmware in the future.

It's quite ridiculous how a $20,000 copier (without accessories) cannot even handle DST properly, and no way to manually disable auto DST switchover when NTP is enabled...

0 Kudos
Valued Advisor
Valued Advisor

Re: AltaLink C8155 and B8155 Stuck on DST

Hi Username_Taken, 

Thank you for using the Support Forum. To manually change the time please see this article for the AltaLink C8155 and this article for the AltaLink B8155. Also take a look at the Configure, Modify or Verify the Network Time Protocol (NTP) article for the C8155 and this article Enable Network Time Protocol (NTP) for the B8155 to confirm you have it setup correctly.  If this does not help please consider contacting your support centre for further assistance.

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos

AltaLink C8155 and B8155 Stuck on DST

Product Name: AltaLink C8130 / C8135 / C8145 / C8155 / C8170 Color Multifunction Printer
Operating System: Not Specified


I have two copiers, C8155 and B8155, that are stuck on DST (Pacific Daylight Time), and the timestamps are one hour ahead of the Pacific Standard Time in the winter.

I am puzzled as I have third C8155 on the same network/subnet and physical location using the same NTP servers and configs, and the third one is correctly falling back to Pacific Standard Time.

Also, the problem with DST appears to be only with the Pacific Time. If I switch to different time zones like Alaska or Mountain Time, the DST is not applied and shows the accurate time for those time zones.

Does anybody know what would be the possible cause, and is there a way to manually override DST, so the timestamps are correct? I still want to use NTP though...

  • Date and Time Setup: Automatic using NTP
  • NTP Servers:;
  • Time Zone: (GMT -08:00) Pacific Time (US & Canada)
  • C8155 Firmware:
  • B8155 Firmware:
  • Physical Location: Vancouver, BC, Canada
0 Kudos