cancel
Showing results for 
Search instead for 
Did you mean: 
New Member
New Member

LDAP search problem: LDAP bindRequest uses DN of user, found in previous search.

Operating System: Other – specify OS in post

We have a problem with setting WC 3345 to use LDAP while scanning to mail.

Device is set to use LDAP (no -S) to AD Domain controller under it's service user.
Device searches LDAP successfully for the first time.
Next time after successful search, it fails.

According to WireShark log, the device tries to bind() to LDAP
* every attempt until first successful (non-empty) result: using username set in WebUI. 
* every time first successful (non-empty) result: using distinguished name (DN) of user, found in search results.
* Until device reboot, it tries to use this user's DN as username

Attached: piece of device configuration

tmp_v187_username.png

Attached: two requests. First is OK, second is faulty.


tmp_v187_wireshark.png

Settings screenshot
tmp_v187_settings.png

Some data:

System Software Version,60.006.07.000
Main controller Version,V2.50.06.07
IOT Software Version,V0.00.39_V1.00
Network Controller Software Version,4.00.50.81
User Interface Software Version,V5.51.00.56.00_19101714
Scanner Software Version,V2.50.06.07
Copy Controller Software Version,V2.50.06.07

 

0 Kudos
1 Reply
Highlighted
Community Manager
Community Manager

Re: LDAP search problem: LDAP bindRequest uses DN of user, found in previous search.

Hi filimonic,

Thank you for using the Support Forum. Please take a look at the solutions for configuring the LDAP settings.  Make sure you have followed all the steps in the solutions.  If you continue to have issues please consider contacting your local support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!