cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

Scan to home AltaLink invalid path

Product Name: AltaLink C8035
Operating System: Other – specify OS in post

Window Server 2008

I have setup Scan to Home using the manually built path. We just did this on a PrimeLink machine, and I used the same settings. But on the AltaLink I keep getting an invalid path error.

Here is a screenshot of my settings.

Screen Shot 2020-02-24 at 12.03.33 PM.png

And this is what the AltaLink is showing when I get the workflow details. As you can see it has some weird characters in there.

Screen Shot 2020-02-24 at 12.06.57 PM.png

0 Kudos
10 Replies
Highlighted
Valued Advisor
Valued Advisor

Re: Scan to home AltaLink invalid path

First upgrade the firmware.

If it still fails, EWS  >Security > Logs > Network troubleshooting. Enable it, do a scan, download the file and open in Wireshark to diagnose

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos
Highlighted
New Member
New Member

Re: Scan to home AltaLink invalid path

Did the firmware upgrade, no change. Here is what the packet capture looks like. It isn't even trying to do the SMB login, its just doing a SMB protocol request. Then I get the login failed error.

Screen Shot 2020-02-25 at 2.21.43 PM.pngScreen Shot 2020-02-25 at 2.19.17 PM.png

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: Scan to home AltaLink invalid path

The General release firmware did exactly that which is why I posted the spar, but if you are indeed using the spar firmware I linked, go ahead and eliminate the negotiation by only allowing SMBv2 on the device

1.PNG2.PNG

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos
Highlighted
New Member
New Member

Re: Scan to home AltaLink invalid path

Yes we are on v101.001.109.33800.

I set the SMB to use v2 like you showed. I got the same result as before. Also I tried doing Workflow Scanning using the default template (which I configured to point at the same share) and it worked. So the problem must have something to do with the Scan to Home

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: Scan to home AltaLink invalid path

Last thing to try, and do to your scenario, I don't expect it to work, but it might, and I have nothing more to offer, so....

EWS > Properties > Connectivity > Setup > LDAP > Edit > Edit > Custom Filters > Email Address Book Filter > Enable Custom Filter and copy& paste this in there

(|(sn=LDAP*)(cn=LDAP*))

2.jpg

 

The fact you don't have the user log in makes all my regular bag of tricks seemingly not apply

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos
Highlighted
New Member
New Member

Re: Scan to home AltaLink invalid path

Thanks for the help Joe. That email filter trick didn't work, but, I've found something that does work. And I'm making sure to Update the workflow templates every time I go to Workflow Scanning.

We are using LDAP authentication for "Log In". I had "Prepend Domain Name" enabled, but I turned it off. Doesn't make a difference.

Then I set Scan to Home -> "Login Credentials to Access the Destination" to "Prompt At Device Control Panel"

So I login as "our_domain\john". Then go to Workflow Scanning, press S2Home, press Scan, get the login prompt again, login as "our_domain\john", and it works. Obviously the double login is annoying. What we would like to happen is for users to login once without having to enter the domain name. Does that make sense?

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: Scan to home AltaLink invalid path

Try disabling prepend domain in the DNS settings for the printer

EWS > Properties > Connectivity > Setup > Wired Profile > Edit > DNS

2.PNG

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos
Highlighted
New Member
New Member

Re: Scan to home AltaLink invalid path

Tried it. It made things not work. 

0 Kudos
Highlighted
Valued Advisor
Valued Advisor

Re: Scan to home AltaLink invalid path

Alright, a few more things to attempt

http://<device-IP>/diagnostics/authenticationQuery.php

http://<device-IP>/diagnostics/stripDomainInfo.php

http://<device-IP>/diagnostics/resolveHostname.php

Test each individually, not all in one go.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe Arseneau
0 Kudos