cancel
Showing results for 
Search instead for 
Did you mean: 
mrclark
New Member
New Member

Unable to open port 21 for FTP.

Operating System: Windows 10

Unable to open port 21 for FTP.


Setup:
I have a remote location running a web cam server. I had an old homebrew AMD64 PC running Windows 7 that I had set up and everything worked well. The web server used nginx and I had five cameras on the web site page. I had Filezilla FTP Server running and was able to FTP the server to upload and download files from a couple of off site Pcs. (Linux Ubuntu desktop with Fillzilla Client and a Windows 8 laptop with Core FTP LE Client)
A couple of weeks ago we had a heavy wet spring snow storm which caused massive power outages. Three days later with power restored I booted the server and it went to boot repair. Long story short, the HDD was flaky and dying. So I bought a Optiplex 2070 and began rebuilding the server.


The server is in a remote location with cable ISP to MODEM, cat5 to a Linksys EA2700 running DD-WRT, and cat5 to the server. The server is a Dell Optiplex 7020 running a fresh load of Windows 7 Pro and updates. (Thanks to Windows Seven on how to do the updates). Web software is nginx 1.17.10 and is running well. I can use Remote Desktop to connect to the server from my Ubuntu desktop and the Windows 8 laptop. The router has Port Forward set for the web server, Remote Desktop, and a web cam wired through a router port.


Here is the problem:
I am unable to connect to the server using FTP.
I have scoured the net for three days trying to find out why I can not connect with no luck.
I have tried:
Forwarded router ports 21, 990, 50000 – 51000.
FTP with and without TLS.
Set access through Windows firewall – no luck.
Disabled Windows firewall – no luck.
Verified clients OK by FTP to other sites.
Verified FTP and Filezilla are enabled in Widows firewall advanced settings.
Checked open ports with “Canyouseeme.org”, ports show open for Web and Desktop, port 21 FAILS.
Deleted and reinstalled Flezilla.
Tried different FTP and loaded Quick&EasyFTP.



Example of Client error:
note – port xxx21 is forwarded to port 21 on the server.
Resolving xxxxxx.xxxxxx.com...
Connect socket #1172 to xxx.xxx.xxx.169, port xxx21...
Can't establish connection --> xxxxxx.xxxxxx.com:xxx21 @ Wed May 06 14:04:56 2020 (0-5)
Connection Failed


Tried telnet to the server on port 21 and it also fails.


Is there something simple I overlooked?
Any help would be appreciated.

0 Kudos
1 Reply
CherylO-Xerox
Community Manager
Community Manager

Re: Unable to open port 21 for FTP.

Hi Mrclark, 

I fail to see how Xerox plays into this setup.  I would suggest trying the support for forum for one of the other companies you mention.  

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!