cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

macOS Preview app scanning shows "Scanner returned an error" message

Product Name: WorkCentre 3025
Operating System: macOS 10.15 Catalina

I have installed the latest drivers from www.xerox.com/drivers site.

When I try to scan a color image using flatbed scanner in Preview application it is able to scan an overview image, but not the actual scan - it just shows an error message saying "Scanner returned an error" and nothing more. I'm scanning over WiFi.

So I tried to debug a little bit and in Console it shows this error:

Xerox: CGImageCreate: invalid image bits/component: 8 bits/pixel 24 alpha info = kCGImageAlphaNoneSkipLast

After this theres the same error message of Preview.app.

By the way, this has been happening since macOS Mojave. And so on one of my Macs that's running the latest OS it's unusable, but it works on another Mac that's running macOS High Sierra.

 

0 Kudos
1 Reply
Highlighted
Community Manager
Community Manager

Re: macOS Preview app scanning shows "Scanner returned an error" message

Hello gusc,

If you have not already resolved this issue, we suggest you search our online knowledgebase for this product: WorkCentre 3025.

Alternatively, you can visit our Contact Us page for other support options.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos