cancel
Showing results for 
Search instead for 
Did you mean: 
Alex_G
Member
Member

Issues with User Access in 6.1

I'm having trouble using the Workflow Mapping feature added to User Access in 6.1.

The attached video shows that I opened a user and deselected the second workflow in my Workflow Mapping list, "B-W_to_Color". However, when I open the submit job menu, that workflow is still there.

The third workflow in my Workflow Mapping list, "Break Me", is no longer present in the submit job menu. When I go back to User Access and check the user I just adjusted, sure enough "Break Me" shows as deselected and "B-W_to_Color" is selected.

If I try to switch "B-W_to_Color" to deselected, and "Break Me" to selected (as I intended to do initially), I am unable to save my changes.

0 Kudos
5 Replies
Hans995496-XRXL
Xerox Analyst
Xerox Analyst

Re: Issues with User Access in 6.1

I have FFC v6.1 installed and the user workflow mappings appear to be working as intended, testing both Administrative and Operator level access. However, I noticed that changing the mapping did require a logoff and logon for it to update.

Was the system upgraded from v6.0.x to v6.1? If so, that could be a contributor.

Whenever installing an upgrade, I create a FreeFlow Exchange Clone beforehand, and restore the Clone afterwards. This has produced predictable and reliable results for upgrades. Without using this process, I have found some presets and functionality may not always work as expected.

0 Kudos
Alex_G
Member
Member

Re: Issues with User Access in 6.1

Hello Hans,

Yes, the system was upgraded from 6.0.3 to 6.1.

Did you mention that because you expected there to be issues associated with going from v6.0.x to v6.1, or because you expected issues going from 5.x.x to 6.1?
0 Kudos
Hans995496-XRXL
Xerox Analyst
Xerox Analyst

Re: Issues with User Access in 6.1

In either scenrio, something may occur during the upgrade. Restoring the Clone from originating version has proven to resolve issues that are difficult to recreate or seem unique to a system. At least, that has been my experience.

0 Kudos
Alex_G
Member
Member

Re: Issues with User Access in 6.1

I have import a clone that I created in 6.0.3.
No change in the behavior, the issue still is present.
0 Kudos
Hans995496-XRXL
Xerox Analyst
Xerox Analyst

Re: Issues with User Access in 6.1

Given that information, please escalate the issue to the Hotline.

I do not know if this will yield positive results; however, if you're up for it, a software uninstall and 'deleting the configuration' during the process when prompted will result nearly all things FreeFlow Core being deleted from the system. Then, reinstall the software and restore the FreeFlow Exchange Clone.

Before uninstalling FreeFlow Core and choosing to delete the configuration, make sure you have the FreeFlow Exchange Clone files you want for restoring in a secure location. Please beware of the files that are not backed up by FreeFlow Exchange, and cautious of anything that was created outside FreeFlow Core but stored in the directory structure created by FreeFlow Core, as these files may be permanently deleted by the uninstall process.

Please note: If the SQL database is on a remote server, deleting the configuration when prompted may result in the FreeFlow Core databases being dropped from the SQL server. Depending on the environment, adding the shell databases, OapPlatformDatabase and OapMasterDatabase, may require a database admin. So, please be aware of this and plan accordingly.

Once FreeFlow Core is uninstalled, delete the Xerox directory on the install drive and reboot. Then, install FreeFlow Core as required, reboot, restore the FreeFlow Exchange Clone, and reboot for good measure.

When I do an upgrade in my test environment, I use the process outlined above. As I suggested, it's not for everyone, and use caution when choosing to delete the configuration.

0 Kudos