Showing results for 
Search instead for 
Did you mean: 
2 Replies
Valued Member
Valued Member

Re: Optimize Preset Problem since FFC v5.1.0.10

Thanks Dave.

Email sent.

As for a workaround, I just removed the Optimise Node from the workflow.

0 Kudos
FreeFlow Production Workflow Moderator
FreeFlow Production Workflow Moderator

Re: Optimize Preset Problem since FFC v5.1.0.10

The release notes reflect the changes that were made to the Optimize node -- hence upgrading to should not help. It is possible that the Optimize "fixes" caused an issue with your file(s). You can send a PDF file that causes the problem to me at I'll see if I can recreate the problem or suggest a workaround. A SPAR may be required if I cannot determine a solution.



0 Kudos
Valued Member
Valued Member

Optimize Preset Problem since FFC v5.1.0.10


RE: FreeFlow Core Version: [2019.05.07 20881 01.08].

We run a particular job, that comes to us every quarter, through a workflow which I created a couple of years ago. It's always been used and has worked perfectly until now since I updated FreeFlowCore on 28th May this year from Version

This resulted in us producing the job incorrectly and I need to explore what happened and why. 

tl;dr: The PDF's that are put through the optimse preset to remove objects outside the crop box end up having areas missing/blanked out!


I've narrowed to problem down to the 'Basic Optimization Preset'. More specifically:

Optimise Preset -> PDF -> 'Remove Objects Completely Outside of: Crop Box'


Using a workflow with just a simple optimisation and a Return to CSR:


With Optimisation Settings of only:


Results in the following:
Note: this is a low res image of source PDF page and resulting PDF page, you can see blank areas on the right side of the right hand page where areas have been blanked out.



I thought that maybe the PDF Crop Box values were wrong but they look correct:


I've tested by throwing one of the PDF's from last year through the workflow and the saw the same problem this time. The PDF files this time have been generated the same way as before (for ref, they were generated by an application pdftk 2.02) and they worked fine with previous versions of FreeFlow Core.

So the issue must be down to this version of FreeFlow Core and the way it handles these particular PDF's that I'm passing to it. Something has changed. I see in the Release Notes that the Resolved Issues for version has three entries mentioning 'Optimize' so maybe one of those fixes broke something to cause the issue here?

I do see there's a newer version of FFC (v available but looking at the 'Resolved Issues' sections of the documentation there's only one entry about fixing an issue where jobs hang in the Collect node. So there's nothing obvious there to say this issue has been fixed.

I'm happy to supply an original single page PDF, and the resulting PDF from FFC, for testing, but only via PM and not in an open forum due to GDPR.