cancel
Showing results for 
Search instead for 
Did you mean: 
chasevincent_pi New Member
New Member

Preflight Error Report

Jump to solution

I'm new to the Xerox FreeFlow system and I'm having trouble figuring out if the Preflight reports are saved any place other than the job details? In my current workflow I have a few different preflights that are setup. I have a basic preflight and then based on the results have it routed to a different path that runs some additional preflights. I know on one of the preflights I’m generating errors but it looks like it saves the last preflight report in the process on the job notes. I’m looking to determine if I can view all preflight reports that are run on a specific job, I assume that the reports are saved in a folder on the server someplace but I have not been able to track them down. Any help would be appreciated. Preflight_Workflow.jpg

0 Kudos
17 Replies
Account Deactivated

Re: Preflight Error Report

Jump to solution

FreeFlow Core saves only the last preflight report.

 

If you want the information from the previous preflight reports I would suggest that you add checks from the previous preflight profiles to the last prefilght profile in the workflow.

 

0 Kudos
chasevincent_pi New Member
New Member

Re: Preflight Error Report

Jump to solution

Ok that makes sense, can you access them anyplace other than the job details? We would like our CSR's to be able to access the report so they can email the client but they will not have access to FreeFlow only to some of hte folders.

0 Kudos
Account Deactivated

Re: Preflight Error Report

Jump to solution

You can add an external node after preflight and then call a script (can be as simple as a batch file) to copy the current report somewhere else.

The URI for the preflight report is in the following variable: $FFwfdoc.preflightReport$

 

You can also fully automate this by passing the customer's email to FFCore and then using the external node to invoke a CLI email client.

You can see more details in the following threads:

http://forum.support.xerox.com/t5/FreeFlow-Core/Using-Notification-on-certain-workflows/m-p/110912#M...

0 Kudos

Re: Preflight Error Report

Jump to solution

Hi!

 

I´m having trouble sending the prefilght report using blat. Without report it works jsut fine, but I can´t make the script send the actual report. What´s wrong with my syntax here?

 

Clipboard01.jpg

0 Kudos
JJakubowski Valued Member
Valued Member

Re: Preflight Error Report

Jump to solution

I found it is easier to debug the syntax of external commands by opening a command line on the PC, and typing the command in full there like: C:\blat\full\blat.exe -to somebody@somecompany.com etc.

 

Blat will tell you what it finds wrong with the command.  You can fix it, then copy/paste the parameters back into FreeFlowCore.

You will need to replace the $FFwfdoc-preflightReport$ with a real file name and path like c:\test.txt

Account Deactivated

Re: Preflight Error Report

Jump to solution

I would also do two things:

  • Upgrade to the latest version of FFCore (v4.0.3.3)
  • Use the following variable: $FFwfJob.preflightReportUri$

The variable you are using ended up in the documentation because of a misunderstanding (it's an internal variable). We corrected that misunderstanding by creating a documented variable with the expected information.

 

About debugging scripts. I would endorse the approach mentioned by JJakubowski. Get the script working on the CLI and then copy it into the FFCore preset. Once there you can see the CLI feedback in two XML files FFCore will create when the script executes. There should be a status folder in the script folder in the sandbox (you will need to access the location in the server filesystem). These files contain the output from stdout and stderr (aka the feedback you will see when you invoke the script from the CLI).

0 Kudos
Highlighted

Re: Preflight Error Report

Jump to solution

Thanks Javier and JJakubowski!

 

I´ll try what Javier suggested and thanks JJ for the great tip using the command line as debugging tool!

 

Sami from Finland

Re: Preflight Error Report

Jump to solution

Hi again!

 

Finally had the chance to test this...

 

I can´t manage to get it to work even in Core CLI. Seems that the problem lies in the report file name. Debugger says that blat do not understand the space in the report filename (screenshot). I also tried this from the Core web client itself, returns code -1. If I put a file named A4.pdf to the same folder where the report is and send it with blat, everything works fine.

 

Any suggestions what to do now?

 

Sami from FinlandClipboard02.jpg

0 Kudos
Account Deactivated

Re: Preflight Error Report

Jump to solution

 

Try -attach "C:\..."

 

If there's a space in a path you typically have to put quote marks around the path.

0 Kudos