cancel
Showing results for 
Search instead for 
Did you mean: 
New Member
New Member

Driver fail to install

Product Name: Phaser 3330
Operating System: Windows 10 x64

On a new computer, I have installed the Phaser 3330 printer and had no problem for a week.  After I got a message 'Driver unavailable' (free translation from french).  I notice that an update from Windows failed because of a printer driver. 

I removed all printer and restart the update, it went fine and complete.  When I tried to reinstall the printer, the driver failed to install.

I have tried to reinstall Xerox Print and Scan Experience to install the driver from the web as well as downloading directly to install manually with the same result.

I have successfully install the printer on another computer.  

Has any one have a solution ?

 

0 Kudos
1 Reply
Community Manager
Community Manager

Re: Driver fail to install

Hello Daniel,

If you have tried using the PCL or PostScript drivers and that didn't help either, have you tried use the Global Print Driver?

If that still doesn't help, I would recommend contacting Support to speak with an Analyst for more help: 1-800-821-2797

Thanks,
CathyO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!