cancel
Showing results for 
Search instead for 
Did you mean: 
sd0
New Member
New Member

Firmware Update Tool "developer cannot be verified"

Product Name: WorkCentre 6515
Operating System: macOS 12 - Monterey

I'm trying to install "WorkCentre_6515 Service Pack 65.67.91 ( PL7-R6)" <https://www.support.xerox.com/en-us/product/workcentre-6515/content/154071> using macOS Monterey 12.1 and I get a dialog that says:

“Firmware Update Tool” cannot be opened because the developer cannot be verified.

[I know that I can override this one time in the System Preferences > Security & Privacy pane -- but I don't want to do that.]

Xerox should release a macOS Firmware Update Tool that is properly signed/notarized.  How can I report the problem?  Thanks.

I have already installed the 5.10.2 driver and my printer is currently running 65.66.91 firmware.

Tags (1)
0 Kudos
1 Reply
CherylO-Xerox
Community Manager
Community Manager

Re: Firmware Update Tool "developer cannot be verified"

Hi sd0, 

Thank you for using the Support Forum. I will escalate your concern.  I am glad you were able to get your printer upgraded.  Please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos