Showing results for 
Search instead for 
Did you mean: 
2 Replies

Re: Unable to call web service on Xerox Altalink C8054 from a machine.

Thank you!

0 Kudos
Community Manager
Community Manager

Re: Unable to call web service on Xerox Altalink C8054 from a machine.

Hi huy sy doi, 

Sorry to hear you're having this issue, please contact our Support Department @ 1800-821-2797 for assistance with not being able to call web services. 


Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Unable to call web service on Xerox Altalink C8054 from a machine.

Product Name: AltaLink C8030 / C8035 / C8045 / C8055 / C8070 Color Multifunction Printer
Operating System: Windows Server 2016 x64


During configuration of our application on the device, we call some webservice methods exposed by the device such as JobLimits below.

We couldn't call this service from one of our server machine. 

With the same device, we could call this service from another server machine.

Do you have any ideas on possible cause?

We also tried to post this from Fiddler > Composer > Raw but got no response from the devcie.

POST /webservices/JobLimits/1 HTTP/1.1
User-Agent: gSOAP/2.7
Content-Type: application/soap+xml; charset=utf-8
Content-Length: 814
Connection: close
SOAPAction: ""

<?xml version="1.0" encoding="UTF-8"?>
<SOAP-ENV:Envelope xmlns:SOAP-ENV="" xmlns:SOAP-ENC="" xmlns:xsi="" xmlns:xsd="" xmlns:c14n="" xmlns:wsu="" xmlns:ds="" xmlns:wsse="" xmlns:joblmts="" xmlns:xacfg=""><SOAP-ENV:Body><joblmts:GetInterfaceVersionR...>


We also tried with another webservice method, it has the same issue:

POST /webservices/office/cuiregistration/1 HTTP/1.1

Content-Type: text/xml; charset=UTF-8

SOAPAction: ""

User-Agent: Axis2

Host: <device ip>

Content-Length: 904


<?xml version="1.0" encoding="UTF-8"?><soapenv:Envelope xmlns:soapenv=""><soapenv:Header><ns3:Security xmlns:ns3="" soapenv:mustUnderstand="0"><ns3:UsernameToken><ns3:Username>admin</ns3:Username><ns3:Password Type="">c... left out</ns3:Password><ns3:Nonce>wdigRQA/q8V80XecinD2QQ==</ns3:Nonce><wsu:Created xmlns:wsu="">2020-08-07T17:44... xmlns:ns5=""></ns5:GetInterfaceVersionRequest></soapen...>


Thanks very much.

0 Kudos