cancel
Showing results for 
Search instead for 
Did you mean: 
thucydides
New Member
New Member

Workcentre 7535 boots displaying 7525 branding

Product Name: WorkCentre 7525/7530/7535/7545/7556
Operating System: Windows 10 x64

I have a Workcentre 7535 that was given to me by a parent of one of my special education students. For the last year or so, it has run without any lasting issues until a few days ago. I turned the power on like usual, it displayed a different product: Workcentre 7525Although this is incorrect in my mind, the machine begs to differ, because when the power-up ritual is complete, a roaring cacophany of beeps and a flood of error code windows appear. Long story short: any consumable read by a chip is being rejected (e.g., toner).

Usually, I never need to get on forums like these because of how well the community approaches so many problems and solutions. I got to say...I am stumped on this one. I have gone as far as wiping the hard drive clean and altbooting into a forced upgrade with the latest firmware and it still boots up and displays "Workcentre 7525" on the screen. 

Everything seems to be working fine except for the fact that my Workcentre 7535 believes itself that it is a Workcentre 7525. How can I get my Workcentre 7535 to diplay the correct product number?

0 Kudos
4 Replies
GabiE-Xerox
Xerox Employee
Xerox Employee

Re: Workcentre 7535 boots displaying 7525 branding

Hi,

It is possible that the battery on the SBC board to be drained and must be replaced. Normaly you need a tech because after replacing the battery one machine NVM must be setup.

 

Gabi

0 Kudos
thucydides
New Member
New Member

Re: Workcentre 7535 boots displaying 7525 branding

Would you by chance know the protocol for draining the SBC board battery? I ordered a new one and it is on the way. I will let you know if it works.
0 Kudos
thucydides
New Member
New Member

Re: Workcentre 7535 boots displaying 7525 branding

I am afraid that replacing the battery did not influence any visable changes in the machine. The Device Model is 7525 when I press Machine Status, even though the branding on the machine says it's a 7535. It ran just fine until one day it started booting with the wrong Device Model.

0 Kudos
GabiE-Xerox
Xerox Employee
Xerox Employee

Re: Workcentre 7535 boots displaying 7525 branding

As I said "you need a tech because after replacing the battery one machine NVM must be setup".

0 Kudos