cancel
Showing results for 
Search instead for 
Did you mean: 
mvishchers New Member
New Member

can't install workcentre 7830 printer on debian linux using xeroxprtmgr

Jump to solution

Our company just changed printers and I want to use our WokCentre 8730 with my linux laptop.

 

I could not find a printer description in CUPS, nor could I find a ppd file somewhere, so I installed the XeroxPrtDrv package

Xeroxv5Pkg-Linuxx86_64-5.15.540.3080.deb

and fired up xeroxprtmgr as root. The printer was discovered, but when I try to add it, an "internal error" is reported, and the /tmp/Xeroxquemgr.log says:

13:16:09 - Quemgr:  Request for legacy PPD model identifier - has been deprecated in favor of model OID
13:16:09 - ERROR/OSInterface:  SysCmd() - Command failed: /usr/sbin/lpadmin -p_xeroxtq1_ -E -i/opt/Xerox/prtsys/XeroxXSF 1>>/tmp/OSICmd.log 2>>/tmp/OSICmd.log
lpadmin: Unable to open PPD "/opt/Xerox/prtsys/XeroxXSF": Missing asterisk in column 1 on line 1.
lpadmin: Bad PPD file.

So there seems to be something wrong with creating the arguments for lpadmin.

 

Any help would be appreciated.

0 Kudos
2 Replies
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: can't install workcentre 7830 printer on debian linux using xeroxprtmgr

Jump to solution

Just use a Windows PC to extract the Generic ppd from the exe file and use that in CUPS

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe
Highlighted
mvishchers New Member
New Member

Re: can't install workcentre 7830 printer on debian linux using xeroxprtmgr

Jump to solution

Thank you Joe,

 

that did the trick!