Showing results for 
Search instead for 
Did you mean: 
1 Reply
Valued Advisor
Valued Advisor

Re: 7750 not recognizing a new fuser

Hi hankgood,

Thank you for using the Support Forum. Please take a look at the solution for replacing the fuser. Click on the link and enter the word fuser in the search box to the right.   Make sure you are following all the steps.  If this does not fix the issue please consider contacting your support centre for further assistance.

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
New Member
New Member

7750 not recognizing a new fuser

Product Name: Other - specify product in post

I have installed two new fusers in my 7750 and neither are being recognized by the printer.


I have tried System Diagnostics to reset the count and tried this Postscript Snippet download suggestion for a 7500:


It continues to show 0% life and the old install date - and the control panel continues flashing to install new fuser.


Any suggestions will be appreciated.




0 Kudos