cancel
Showing results for 
Search instead for 
Did you mean: 
Boboche New Member
New Member

8570 Error after Firmware update - Won't go past the Xerox welcome screen

I have a 8570DT printer that was woking okay prior updating the firmware.  The firmware process went #1, no errors or anything, then after the reboot, it froze at the Xerox screen.

 

Now this sounds like a corrupted firmware update... I know....But I looked at the screen throughout the entire process and everything looked okay.

 

Tried booting the printer in various mode, i.e. service mode, cancelling post, ect... I could get to a point where I could print so, moved on until most probably another firmware would show up to correct this issue.

 

Saw an updated firmware with a 29-04-2014 (whereas the other one was a dating back to march) so applied it.... now I can't print.  

 

I Can get in service mode and reflash something but it won't cut it, its like I would need to reformat and flash everything factory.

I tried resetting NVram from manufacturing mode, it got stuck to erasing NVram screen, 10 minutes later, I just gave up.

 

I can hear the hardware initialisation and the clicks like when it was working (last one happening at about 30secs) but won't get past the screen in normal mode.  In manufacturing mode, the paper jams, looks like something is wrong with some internal configuration. nothing will print anymore.

 

 Is it possible to just get a complete image and reflash the thing completely without having to pay even more for this already expensive printer?

 

Thanks for any help or suggestions.

0 Kudos
2 Replies
Community Manager CherylO-Xerox
Community Manager

Re: 8570 Error after Firmware update - Won't go past the Xerox welcome screen

Hi Boboche,

Thank you for using the Support Forum. Please try resetting the machine.  If you are unable to do this or if it does not work please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
JeroenWit New Member
New Member

Re: 8570 Error after Firmware update - Won't go past the Xerox welcome screen

Maybe this will will help you further:

 

Printer hangs at Xerox logo

Problem:

The printer hangs at Xerox Logo, and freezes without telling you anything.

Cause:

The configuration card is registering in the printer but seems to be defective

Remove the configuration card... If the printer tells you that it is missing after the logo, then your config card is defective.

Solution:

Order a new configuration card

 

Kind Regards,

 

Jeroen Wit

 

0 Kudos