Showing results for 
Search instead for 
Did you mean: 
1 Reply
Valued Advisor
Valued Advisor

Re: B310 High fuser temperature. Restart the printer. [121.50A] Service Error

Hi Generic, 

Thank you for using the Support Forum. Please make sure you have followed all the printer installation instructions for space requirements and room temperatures found on page 28 of the User Guide.  If the installation instructions for clearance around the printer is not followed it could cause over-heating and potentially the code you are seeing.  

If the requirements are met and you continue to get the code, please consider contacting your support centre for further assistance.

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

New Member
New Member

B310 High fuser temperature. Restart the printer. [121.50A] Service Error

Product Name: Xerox B310 Printer
Operating System: macOS 10.14 - Mojave

I have a 2-month-old printer and there is a Xerox B310 printer error message. Did about a 30-page print job then this error shows up. 

High fuser temperature. Restart the printer. [121.50A] Service Error

The above error message is from telneting into the printer. I have also updated the firmware via the printer webpage online.  Even after updating the firmware, the same error persists. 

Have done a printer restart by holding down the power button for more than 10 seconds until it reboots itself, the same error message shows still shows. 

Have done a cold power down, unplugged the printer from a wall outlet and have tried a different building wall outlet, and restarted the power on the printer, which still shows the same error. 

When checking online through the replacement there are no fusers available to purchase.

When googling the Xerox B310 I can't see if there other people that may have a similar experience as I am going through. 

Not sure what options I have? 


Tags (1)
0 Kudos