cancel
Showing results for 
Search instead for 
Did you mean: 
EGovaert New Member
New Member

Black display after move

Product Name: WorkCentre 7525/7530/7535/7545/7556
Operating System: macOS 10.12 - Sierra

Hi,

I have recently moved my WorkCentre 7535 to a new location and dis-/reconnected the external printer cables. After powering up the printer, everything works except the display.

I hear everything power up, all the right noises... the display gets power the first seconds and I see a white/grey screen, but after that, it stays black. After the printer is powered up completely I can even hear the typical beep-sound when I touch the screen at the location the buttons normally are, but I can't see them. Also, the printing computer is making a lot of noise. It always did, but now it seems to be constant and louder, I don't know if this is related to the display.

I can still find the printer in the network and can still login via the web interface but using it is unpractical as I cannot handle messages on the printer itself.

I guess there is a display cable that is not fully plugged in or something else that came loose during the move but I have no idea where to start. I did reconnect all the external cables and I removed the printing computer and refitted everything on the board but nothing changed. Can I get some sort of diagnostics report from the web interface? Anyone any idea on how I can fix this problem myself? The manual is not that useful in this case.

Thanks in advance!

Kind regards.

0 Kudos
1 Reply
Highlighted
gabiene Occasional Advisor
Occasional Advisor

Re: Black display after move

Hi,

It is possible  to be a bad connection. Try to take out the SBC board (that one with network port on it). For this unscrew the three thumb screws: one in the upper position, one in the lower position and the last at the handle and after that take the handle and pull out the board. Then reinsert the board and power up the machine. And if this not work try to remove the control panel (it have 4 screws) and disconnect and reconnect the communication cable.

 

Gabi

0 Kudos