cancel
Showing results for 
Search instead for 
Did you mean: 
TonyGH New Member
New Member

Compatible cartridges and firmware

Product Name: Phaser 6510
Operating System: Windows 10 x64

Hi, hopeing someone may have some answers or could point me in the right direction. We bought a phaser 6510dn brand new and while it was still in a factory state - still on the factory cartridges - we tried 2 different premium high capacity compatible toner cartridges. The result was 'Incompatible toner' in each case. We upgraded the firmware to 64.31.81 and tried again. Same result. We then bought a genuine xerox high capacity toner cartridge and put that in. Great this worked, Genuine Xerox message came up and the 6510 accepted the cartridge. We have just bought another compatible cartridge from the same supplier as the original since if they sell the genuine ones then their compatibles must work. Tried it in the printer and got the incompatible toner message. Very strange.

Googled around a bit and found someone who was saying that compatible cartridges wont work with firmwares issued after Oct 2017, not sure how true this is as xerox aren't supposed to restrict customer choice in this way.

Is there an archive of firmwares for the 6510 in order for me to roll back the firmware to test which firmware will work with compatible cartridges?

It can't be a xerox code snippet that's needed because it's always had genuine cartridges used in it.

Thanks in advance.

0 Kudos
3 Replies
Community Manager CherylO-Xerox
Community Manager

Re: Compatible cartridges and firmware

Hi TonyGH,

Thank you for using the Support Forum. Please try one more thing if you have not, turn the machine of remove the cartridge. Turn the machine back on with the toner out.  Once it has booted it should show a message that the toner is not there.  Turn the machine off again and insert the toner then turn the machine on again.  If it still fails please consider contacting your local support centre they are the only ones that might have access to an older firmware  version.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
TonyGH New Member
New Member

Re: Compatible cartridges and firmware

Hi CherylO-Xerox,

Thanks for taking the time to come back to me on this. Unfortunately I just tried this and it didn't work. Is there anyway that this printer could be locked to only being able to use genuine cartridges? I ask this because as you'll see from my thread I've tried 6 compatible toner cartridges in this machine and all fail with incompatible toner error. Of the 4 compatibles I have had 2 from each supplier and have checked with them each time on whether there are any issues that anyone else has had with these cartridges in terms of them not working. The cartridges are being bought from companies that specialise in selling toners, both genuine and compatible, and also based in the uk. It can't be a regional error as the initial toners where factory toners. 

Is there any way to check if the machine is set to only accept genuine cartridges? I know on some xerox machines it's a setting in the admin menu but I can't find it.

Thanks

Tony

0 Kudos
Analyst Nation Moderator Joe053204-xrx
Analyst Nation Moderator

Re: Compatible cartridges and firmware

Make sure it isn't a glitch by simply updating the firmware

Machines are sold as open from Xerox, they are not region locked or contracted until you put in the first replacement toner/drum etc..

The first (not packaged with it) supply you put into them encodes the status/contract/region of the device.

 So you have regions, which are NA/DMO and Asia pacific

And you have contracts, which are Metered (On a contract with Xerox) and Sold (purchased retail)

So you bought from somewhere, used up the original supplies and threw in a cartridge, the machine locked itself to the region and contract programmed to that item. And until you can find out what that was, you are pretty much out of luck, it could get costly. Xerox can convert the machine back to open status, but they won't do it for free, and in the case of using a 3rd party, it would likely just get your warranty voided at the same time.

 More in depth info

I apologize, but I don't have any idea how to tell what region or type a device is set to. Hopefully someone may see this and chime in with a way to check.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

Joe.
0 Kudos