cancel
Showing results for 
Search instead for 
Did you mean: 
DHH_NL New Member
New Member

Copycentre C128 start-up problems

Hi all,

 

We own a Xerox Copycentre/Workcentre C128 (with duplex module, no finisher, also to use as network-printer) which does not start up anymore.

 

When turning on the power, the printer is loading (also visible on the touchscreen), which is normal.

 

But here te start-up / init process stops after a period (loading bar still visible, at 60%) and the system freezes while normally the 'All services' screen appears.

 

Also the following led-lights are flashing (green) on the keyboard: Interrupt, Machine status, Job status, features

 

The copier is not part of a computer network (so operates stand-alone, sometimes connected to a PC by using USB interface), and also not used as fax. I already disconnected the duplex module, which has no influence.

 

Any ideas?

0 Kudos
3 Replies
Community Manager CherylO-Xerox
Community Manager

Re: Copycentre C128 start-up problems

Hi DHH_NL,

Thank you for using the Support Forum. Please make sure the machine is plugged in to a dedicated outlet and not an extention cord.  If this does not help please consider contacting your support centre for further assistance.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
DHH_NL New Member
New Member

Re: Copycentre C128 start-up problems

Hi CherylO-Xerox,

 

There was an extension cord used. This is now removed, but still the same problems. Resetting the printer (using the button on the back) does not work.

 

Any other ways to force a reset? 09062012023[1].jpg

Thanks in advance,

Glenn van Rijn

Netherlands

0 Kudos
Community Manager CherylO-Xerox
Community Manager

Re: Copycentre C128 start-up problems

Hi Glenn,

You might try turning it off and unplugging the machine for 60 seconds if you have not already done so.  While the machine is off please check all the cable connections including the power cord to make sure they are secure.  Then plug it back in to the dedicated outlet and then turn the machine on. If the machine still stops in the process of start-up then it is finding a problem during the diagnostics done during the startup.  You will need to contact service for help with the machine. 

 

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos