cancel
Showing results for 
Search instead for 
Did you mean: 
TrumbullTechs New Member
New Member

DocuCentre 430ST - Drivers

What's the deal with XEROX and no longer providing updated drivers for the DocuCentre 430ST?  We have had a technology refresh in the office and ONLY 1 PC is left on Windows XP.  Once that one gets upgraded we will NO Longer have complete functionallity to that printer.  How difficult is it to create current drivers for Windows 7, and now Windows 8.

 

All support tells me is they will put me in contact with Sales to discuss a new printer.  UNREAL!!!!

 

Has anyone else had the same issue?

0 Kudos
3 Replies
Community Manager CherylO-Xerox
Community Manager

Re: DocuCentre 430ST - Drivers

Hi TrumbullTechs,

Thank you for using the Support Forum. Please consider using the Xerox Global Print Driver for your machine.  This driver will work with your machine and your updated Windows OS.  This is the only option for the machine you have.

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos
nurisers New Member
New Member

Re: DocuCentre 430ST - Drivers

The Xerox Global Print Driver failed to work.  See my recent post.

0 Kudos
Kimzi Valued Advisor
Valued Advisor

Re: DocuCentre 430ST - Drivers

Hi nurisers, you're hijacking someone elses thread?

 

The Windows Vista driver have been reported working for some printers on Win 8.1, you can try with that and see if that helps.

When you use the global print driver, you will need to select the exact printer in advanced settings, for the driver to emulate the correct type of settings, have you done that?

 

Xerox are not slow on keeping the drivers up to date, they are just not interesting in investigating a lot of money in an old printer. Which means they will not update the drivers for this machine.

 

Best Regards

Kimzi


--------------------------------------------
Please remember to select "Accept as Solution" for posts that helped you solve the issue.

0 Kudos