cancel
Showing results for 
Search instead for 
Did you mean: 
FrankNFurter
New Member
New Member

Firmware Update failed, Printer is dead!

Product Name: WorkCentre 6515
Operating System: Windows 11

Hello,

I had problems with the scan unit and looked for the firmware version of the printer. It had the version 65.10.41 from 27.10.2017, so I decided to bring it to the actual version. The documentation said that I had to do it in two steps, first upgrade to 65.59.11 and in a next upgrade step to the actual version.

I performed the following steps:

- download and unpack 655911_WC6515.zip

- download and unpack fwdl5.3.6.19ww-20211006-1.zip

- copy binary firmware file to die FWDL folder

- starting firmware update tool: selecting the binary, selecting the printer and start update

 

After approx. 10 min the FWDL worked on the update and finished. The printer restarted, but the screen was blank and the home button was slightly blinking. Ten minutes later nothing had changed. The printer did not react on button pressing of the power or home button. Nothing worked, so I decided to put off power, waited a minute and powered on again. Now I see a blue screen with "Xerox" on it, but nothing happens. The printer does not show itself in the network. I tried to make the firmware update again with an USB cable, but the FWDL does´nt find the printer. The printer is really dead. 

What can I do? I´ve really no idea.

 

Best regards,

Frank

 

 

Tags (1)
0 Kudos
1 Reply
CherylO-Xerox
Valued Advisor
Valued Advisor

Re: Firmware Update failed, Printer is dead!

Hi FrankNFurter, 

Thank you for using the Support Forum. Sounds like you have tried everything already, so it would be a hardware escalation: 1-800-821-2797 or 1-800-835-6100. 

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!