Showing results for 
Search instead for 
Did you mean: 
2 Replies

Re: Firmware update error 017-759

After having rebooted the computer and the printer two or three times, I finally managed to install the Bridge version 65.59.11.

However, the panel of the printer shows immediately 4 Fault or Error : 





I tried to install the latest version of the firmware 65.67.91 to solve these problems, however the printer didn't accept this.


I rebooted the printer three times, and then tried again to install the firmware 65.67.91 onto the printer.

To my surprise, this time the installation was successful. And with the success of the installation, the four above errors disappeared simultineously. 


It took me 9 hours to get my new printer ready for work with latest firmware.

I haven't met such problems for about 2 decades. Xerox, please make SIMPLE-to-USE products : the printers works for us, not we work for the printers.

0 Kudos

Re: Firmware update error 017-759

It was the day I received the brand new printer that I found the update of firmware was mission impossible.

How could this happen, Xerox ? Just do something and solve the problem.

0 Kudos

Firmware update error 017-759

Product Name: WorkCentre 6515
Operating System: macOS 12 - Monterey

I just received today my first Xerox printer, the Workcentre 6515 DN.

It's OKI printers that I used in the past 15 years, simple and stable machines.

It was a little bit complicated to get 6515 DN hooked to my Mac computer, yet I succeeded and got the startup page printed and several documents printed.

The current version in the printer is 65.51.61.

The latest version on is 65.67.91, which would be installed after having installed the bridge version 65.59.11. 

The problem is the bridge version supports only the Catalina 10.15 MacOs platform while my mac has the Monterey 12.2. It's neither possible to downgrade the platform of my mac to Catalina 10.15 nor pooible to find a mac with old catalina 10.15.

This means the installation of the bridge version is mission impossible, and as a result the latest version 65.67.91 and maybe any newer versions is/will be nothing but a cake on the moon that I can never reach for my printer. A nightmare.

Any experts here can help me out ? Any suggestions or solutions are warmly welcome.


0 Kudos