Showing results for 
Search instead for 
Did you mean: 
1 Reply
Community Manager
Community Manager

Re: Firmware update fails, mchine locked

Hello bryanpreas, 

I would suggest that you call into the support center at 1-800-835-6100 since this is a brand new printer in case it's a hardware issue.  

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Firmware update fails, mchine locked

Product Name: WorkCentre 6515
Operating System: Windows 10 x64

Brand new WC 6515. Just set up. I'm using a Dell XPS x64 laptop runing Windows 10 with all updates.

Tried to update firmware to the Bridge version 65.59.11 as described in WC6515 documentation. I used the latest VersaLink Firmware Install Utility v5.3.6.19. All went exactly as described in the documentation. Except the WC 6515 did not reboot after I clicked "Finish" at the end of the process.

After a 30 minute wait I tried to turn off by using the power button. No response. I pulled the power cord and reconnected. The control panel shows Xerox an logo. Doesn't ever get beyond this. Can't get to the embedded web server. 

All the firmware failed questions on the support forum assumes that the control panel or the embedded web server is active. I can't get that far.

Please help. Thanks.



0 Kudos