Showing results for 
Search instead for 
Did you mean: 
New Member
New Member

Re: Firmware upgrade failed for Xerox Versalink c405 - write error 041-500 - printer bricked

Anyone care to respond to this? I'm having this identical issue after the automated firmware update failed from the control panel. Same exact error.

I attempted to use the Windows firmware utility to install the latest firmware service pack, but it says that "the firmware selected doesn't match with the device" despite it being the correct one.

New Member
New Member

Firmware upgrade failed for Xerox Versalink c405 - write error 041-500 - printer bricked

Product Name: VersaLink C405 Color Multifunction Printer
Operating System: Windows 10 x64

DUe to various issues with the printer including inability to do remote update (connectivity problems) and failed print jobs due to incorrect default tray selection - I have decided to upgrade the firmware to the latest available version 68.67.91.  The instructions said to install bridge version 68.59.1 first.  I checked the existing version using web interface and it was showing 68.59.1, so I started the upgrade to 68.67.91 via Web Interface.  AFter the upgrade started, it was stuck at 12% for some time, then immediately moved to 75%, stuck again then ended up with the message "write error 041-500" on the red screen. I waited and nothing else happened within one hour. Then I tried to reboot the printer and now it comes to the blank screen instead of control panel, and I am unable to connect to it via Web Interface. ALso, connection via USB port no longer works as well. I tried to restart the printer, and one or two times it said "checking file system" but would get stuck at that message. I also noticed that holding power button and home button at the same time while trying to turn on the printer brings it to a "special boot menu"  offering "HDD initialize mode" and "Storage device initialize mode" but one of the modes does nothing and second mode shows "file system checking" screen which does not do anything else - even overnight there is no change to the screen.  Can Xerox post instructions what have to be done in this case? 

I saw similar thread where Xerox employees offered to provide instructions by email - can they be posted here?

Also, is it possible to explain the "Special boot menu" for Xerox Versalink c405 as I could not find the explanation anywhere....