Showing results for 
Search instead for 
Did you mean: 
1 Reply
Community Manager
Community Manager

Re: Got a new Computer can't get C75 installed

Hello digitalprintplus,

If you have tried the drivers from the Xerox page and they didn't work you may need to go to the EFI page and try the Fiery driver.

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Got a new Computer can't get C75 installed

Product Name: Color C75 Press
Operating System: Windows 11

Hi there guys don't know what I'm doing wrong but I'm unable to get the C75 reinstalled on the new computer. 

I have tried via Ip no luck 

I've downloaded the software installer and found the fiery URL and tried that still no luck

Can anyone provide some support, please


We installed two new computers, one was ghosted HDD so everything came over the other wasn't couldn't be able to so we did new Windows install but got on all the other printers in the shop but the C75. 


Tags (1)
0 Kudos