cancel
Showing results for 
Search instead for 
Did you mean: 
paulfreeman
New Member
New Member

Machine locked after failed firmware update

Product Name: VersaLink® C405 Color Multifunction Printer
Operating System: Windows 10 x64

Agreed to let machine carry out firmware update, but it is now stuck on Xerox start up screen and unable to do anything else. Tried to access special boot menu but that failed also. Spent 45 minutes on the phone to 'technical support' in the US only to be told it is out of warranty and I now have to wait 24 hours for a quote for an engineer visit. All I wanted to know is how to do a factory reset, or force the machine to start with downloaded firmware. Anybody know how to fix what seems to be a very common problem. Machine is only 2 years old and only done maybe 200 copies but it seems that it may already be scrap. 

0 Kudos
2 Replies
gabiene
Valued Advisor
Valued Advisor

Re: Machine locked after failed firmware update

Hi,

Under Special Boot try FActory Init Mode.

 

Gabi

paulfreeman
New Member
New Member

Re: Machine locked after failed firmware update

Tried that initially, but it made no difference. Have now been waiting 12 days for Xerox to quote for an engineer visit to fix this problem. Terrible customer service. I get passed between the Phillipines and Ireland when all I want is to reset the machine to factory settings or install operational firmware. If I need an engineer visit then please tell me the cost and when the work can be done. Why is it so difficult. I think that the company are only interested in new sales and do not care about after sales service at all.

I email, but get no response. How can companies so large treat their customers this way and get away with it.

Never again will I buy Xerox.

0 Kudos