cancel
Showing results for 
Search instead for 
Did you mean: 
JLeslie Member
Member

Need Xerox 510 driver on Server 2012 for Win7 x64

I have a new print server running Windows Server 2012. I migrated all of the printers, drivers, etc from the old print server which ran Server 2008 R2. One of the printers is a Xerox 510 Series Wide Format with FreeFlow Accxes.

 

The problem is that when users try to print a pdf document, they are unable to select the print properties within Adobe Reader. I have verified this, I get an error that says "Function address "address" caused a protection fault. (exception code 0x00000005) Some or all of the property page(s) may not be displayed.

 

This must have something to do with Server 2012 but I have no idea how to fix it. I tried deleting the printer and drivers, rebooting the server with driver signing disabled, then recreating the printer and installing the only 510 driver I can find which is unsigned. But when trying to view the printing properties within Adobe Reader, the above error still appears.

 

Does anyone know of a signed driver for the 510 Wide Series? Or is there another fix for this issue?

 

Jonathan

0 Kudos
4 Replies
Kimzi Valued Advisor
Valued Advisor

Re: Need Xerox 510 driver on Server 2012 for Win7 x64

Heya!

 

This problem usually occures when a dll file used by the driver gets damaged or could also be because of the spool service.

 

I would suggest you stop the spooler on the client and go to C:\Windows\System\spool\printers and delete everything you got there if possible, and try again.

 

If that does not work, it could be a lil trickier.

Download the driver on the client, and copy/paste the dll files to the system folder and see if that works.

 

Hope this helps

Thanks!


--------------------------------------------
Please remember to select "Accept as Solution" for posts that helped you solve the issue.

0 Kudos
JLeslie Member
Member

Re: Need Xerox 510 driver on Server 2012 for Win7 x64


@Kimzi wrote:

Heya!

 

This problem usually occures when a dll file used by the driver gets damaged or could also be because of the spool service.

 

I would suggest you stop the spooler on the client and go to C:\Windows\System\spool\printers and delete everything you got there if possible, and try again.

 

If that does not work, it could be a lil trickier.

Download the driver on the client, and copy/paste the dll files to the system folder and see if that works.

 

Hope this helps

Thanks!


--------------------------------------------
Please remember to select "Accept as Solution" for posts that helped you solve the issue.


I did already try deleting everything and reinstalling the driver newly downloaded from Xerox. But it still won't allow viewing the printer properties within Adobe Reader, but gives the error I stated earlier.

 

The printer properties can be viewed with no problem from within the printer itself when you go to Devices and Printers, right-click the printer and choose Printer properties, then select Preferences on the General tab. But then you'd have to go in there and change the preferences every time you wanted to print a PDF file with different options rather than changing it for that one document within Adobe Reader.

This Xerox 510 is the only one that causes this issue. We have HP and Toshiba printers and in Adobe Reader you can view the printing preferences for any of those printers, just not the Xerox. But then the Xerox is the only printer that I can't find a signed driver for. The HPs and Toshibas all have signed drivers.

0 Kudos
Highlighted
Kimzi Valued Advisor
Valued Advisor

Re: Need Xerox 510 driver on Server 2012 for Win7 x64

Heya!

 

Did you also copy over the dll files? even the protected files needs to be overwritten.

If so, then I have no further suggestions, sry.

 

Thanks!


--------------------------------------------
Please remember to select "Accept as Solution" for posts that helped you solve the issue.

0 Kudos
JLeslie Member
Member

Re: Need Xerox 510 driver on Server 2012 for Win7 x64


@Kimzi wrote:

Heya!

 

Did you also copy over the dll files? even the protected files needs to be overwritten.

If so, then I have no further suggestions, sry.

 

Thanks!


--------------------------------------------
Please remember to select "Accept as Solution" for posts that helped you solve the issue.


Yes, all files were copied. Hopefully someone will have a solution. I wish Xerox had a signed driver, I'm sure that would fix the whole thing.

0 Kudos