cancel
Showing results for 
Search instead for 
Did you mean: 

Need older Firmware update utility

Product Name: WorkCentre 6515
Operating System: Not Specified

We have several printers on firmware 65.31.81, trying to get them up to at least 65.59.11.   I've tried the update utility 5.3.6.0, 5.3.6.19, and the more recent 5.3.7.2.  Printers on that firmware always fail with a message "Failed to connect the device with the specified address" when updating via the network on port 9100.

If the printer has firmware version 65.50.61, I don't have any issues, the latest update utility works just fine.

Where can I get an older update utility? 

I can't use the USB option, we have 100's of remote printers and I need to update via the network.

Tags (1)
0 Kudos
1 Reply
TammyL-Xerox
Community Manager
Community Manager

Re: Need older Firmware update utility

Hello deredglen11, 

I suggest that you call into the support department @ 1-800-835-6100 to see if they have an older version available. 

Thanks,
TammyL-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!