cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
New Member
New Member

Phaser 8560 display blank. Not a faulty control panel.

My boss has two identical Phaser 8560 printers and one of them has stopped working. The printer shows a solid red light on the control panel, no display on the LCD. It does not seem to go through the warmup phase either.

 

Looking online I saw that the control panels are known to go, especially in an electrical storm, etc. (we are in Florida, USA) and figured that to be the problem. Swapped the two control panels and no luck. The CP from the non-working machine worked fine on the other Phaser. The swap did not help the non-operable one at all.

 

Can someone point me the way to some possible options to either fix or diagnose what we're dealing with here?

 

Many thanks in advance.

0 Kudos
1 Reply
Highlighted
Community Manager
Community Manager

Re: Phaser 8560 display blank. Not a faulty control panel.

Hi Imaginepieces,

Thank you for using the Support Forum. So through your troubleshooting we know that it is not the control panel itself.  That obviously means that there is an issue with the machine itself.  It could be a power issue since you are not seeing it go through the start up.  Please take a look at this solution for verifiying the power source and see if this makes a difference. If not then please consider contacting your support centre for further assistance. 

Thanks,
CherylO-Xerox
Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

0 Kudos