Showing results for 
Search instead for 
Did you mean: 
1 Reply

Re: Phaser 8560 not printing



I'm done.


Spent the afternoon looking for a replacement  printer.


Adios, Xerox.

0 Kudos

Phaser 8560 not printing

Product Name: Other - specify product in post

My Phaser 8560 has been giving me problems for a while —  but usually is  just slow to recognize  Photoshop  CS6 documeents  sent from my Mac, which is just 5 feet away. But today it also was unable to recognize  an 8" x 8"  document  I wanted to print on card stock.


Usually  the type of paper doesn't matter — especially if I load it manually from the top tray, but today it was just slow to load with paper in either tray  — even after I specified the type and slightly smaller dimensions of the paper I wanted to use.


When it finally did run, it printed one time, but the next time I tried — it started to grind away. I tried removing the maintenance kit, which seemed to be causing the problem, but initially it was stuck and after removing it and getting it back in comfortably, it started making noises again.


I recall having a similar problem with my last Phaser, which I think  was related to the maintenance kit as well — which may have been causing the processor or some other part to dislodge. I never understood the mechanics at the time, and the cost of repair was  so high, it made more sense to just trade it in for the 8560, which  probably was being phased out at the time.


But this time I at least have a printer error message, which I hope someone can decipher for me; meanwhile, since I'm bracing for bad news, as soon as I post this call for help,  I think I'll  head to Office Depot, to look for a printer that  costs less than the cost to repair my 8560.


By the way, the printer error number is:



0 Kudos