Showing results for 
Search instead for 
Did you mean: 
2 Replies

Re: Printer not detected

Thanks for the advice. Eventually traced the fault to a network connection. Working fine now.
0 Kudos
Community Manager
Community Manager

Re: Printer not detected

Hello don_macleod, 

Please check out this article for unable to connect to the network for some trouble shooting steps to try. If you are still having issues after trying these steps, I suggest that you call into our support department for assistance @ 1-800-835-6100. 

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!

Printer not detected

Product Name: Phaser 6510
Operating System: Windows 10

Hoping someone can help with my connection problem.

My Phaser 6510 is connected to my network via ethernet. I don't have a WiFi card installed. My router detects the printer, identifies it as a Xerox printer and allocates it an IP address. However, that's as good as it gets.

Xerox Smart-Start cannot detect the printer and neither can the Windows Add Printer Wizard. I tried forcing a manual install onto the IP address and its not detected. I tried pinging the IP address and nothing. I've also set the IP address within the admin menu to static and to the IP address shown on the router and still nothing - although it did get rid of the Set Primary Net warning. The printer config page confirms the IP address as being correct.

I can connect to it using my laptop over USB but this isn't very satisfactory. While connected to the laptop I upgraded the firmware thinking that might have been the problem but no.

I also tried to install it onto my home server running Windows Server 2012 R2 and no success there either.

Everything else connected to the router works fine.

Any suggestions as to where to go from here?

Thanks in advance.

Tags (1)
0 Kudos