Showing results for 
Search instead for 
Did you mean: 
2 Replies
Valued Advisor
Valued Advisor

Re: WC 4150 firmware problems

i also read in another tip that opera browser seems to work :)

0 Kudos
Valued Advisor
Valued Advisor

Re: WC 4150 firmware problems

here is a possible solution what i read in this tip below


use iexplorer < 8 , or a connection with the laptop straight to the machine without router/switch...


When attempting to upgrade printer firmware using the Firmware Upgrade utility in CWIS. The upgrade file can be selected and the Install Software button is pressed, then the Browser will pop up a window with an "Internet Explorer is unable to display the webpage" message. The file will not arrive at the printer, and the printer UI will not change to Software Upgrade mode.
The problem has been observed in Internet Explorer 8 and some other Internet Browsers (Google Chrome, Mozilla Firefox). The root cause of the issue is unknown at this time.


Use the ControlCentre method of upgrading the firmware via USB using GP6 in the EDOC. If you are unable to use the USB method for some reason, and alternate method can be used, but is slower. The alternate method is to access the Printer's CWIS page in an Internet Browser using a laptop and crossover cable. Select the Print tab, and scroll down to "Browse". Select the firmware upgrade file ending in ".hd" and select the file. The filename should populate in the "File" box. Select the "Submit Job" button and the file will be sent to the printer. The printer should then process the job and revert to a "Software Upgrade in Progress" message on the printer UI. If the printer begins printing gibberish pages, cancel the job and attempt again. If you are unable to initiate the firmware upgrade using this method, then you will have to use the ControlCentre method via USB.


0 Kudos

WC 4150 firmware problems

Product Name: Other - specify product in post

Trying to solve an issue in upgrading our firmware from .42 to .71.


First, we have tried hooking two different computers directly up to the USB service port. When we try to run the Printer Settings Utility software (never run before and newly downloaded from Xerox), both systems give us a "Document FAILED to open" message, and nothing else. So the direct-connect method is DOA at this point.


In trying to update via the web interface, our error messages are miss or very miss, depending on the system and the browser used. The closest we have gotten is a "Some errors were reported - Printer is busy" message. This appears after confirming our desire to upgrade the firmware and after a new, blank window opens for 10 seconds. For the record, neither Firefox nor IE8 was willing to work in attempting to upgrade - received an "Invalid file/path name" error - despite the interface working for all other aspects of printer control. Ended up downloading Opera. We are using XP systems.


Here is what we have tried:


Disabled firewall (XP) and anti-virus (MSE)

Made sure no one was using the printer and that it had no jobs in the queue

Using firmware downloaded from Xerox


Reference was made to selecting "Disable SSL" under the Protocols section of the web interface. However, this option is already set, and the ability to change it is locked as the dropdown is grayed out. In order to un-gray it, you must turn off HTTP Enabled, but doing so will disable the web interface and then you can't use it to upgrade the firmware. (Catch-22, or am I missing something?)


Other errors we have received (using other browsers and systems) after the white box include something about the printer accepting files - sorry that I did not write it down.


So we are left with software (PSU) that won't open on two different computers, and a web interface which is reporting errors due to the printer being (falsely) busy.


One other sidenote, we are using an Apple Airport Extreme router if that makes any difference. Xerox has been providing support via e-mail, but hasn't suggested something that we haven't already considered.




Thanks in advance,


0 Kudos