Showing results for 
Search instead for 
Did you mean: 
4 Replies

Re: WorkCentre 6515 firmware update fails

OK whatever Xerox had been done within the past few days.
After contacting CathyO-Xerox I got the reply that the issue is already fixed and I should check forum for other successful update feedback.

After reading those lines I gave the firmware update another chance and downloaded it again.
Checked the files contained in the zip archive: Only the description pdf file seems to be new - the firmware file itself was dated to 2022-09-07 (as the old file was).

Interestingly this time the update was successful!

0 Kudos
New Member
New Member

Re: WorkCentre 6515 firmware update fails

Hi Cathy,

Thanks for your response.  However, the link provided appears to be the same firmware.  No changes in file sizes after downloading and unzipping.  I just attempted to install the firmware that was downloaded from the link that you provided.  With the same failed result.  I have a friend that has the same printer, and he receives the same failure error.  I have previously updated the firmware numerous times as new releases were posted on your website.  I've never had a problem.

I tried calling support directly, however they want to charge for a support call when this most likely is a problem with the firmware file.

Is it possible for you to have the firmware group attempt to install this firmware on a WorkCentre 6515 in-house?

Can you please provide the link for the release prior to the release in question?  As I even tried downgrading the firmware to 65.59.11 and then attempted the update.

Again thank you for your time and response.


Re: WorkCentre 6515 firmware update fails

Hello @CathyO-Xerox,

thanks for your reply I'm facing the exact same issue.

Sadly the firmware files are not fixed - they are the same version and timestamp.
Downloaded them today 2 times and the issue is still present - no update possible.

May I ask you for two things:

  • please ask the developers to release a fixed version and remove the faulty one from public downloads
  • please provide a link to the latest version of the firmware that is known as working

Thanks for your support.

BR Ralf

0 Kudos
Community Manager
Community Manager

Re: WorkCentre 6515 firmware update fails


We have been informed that they have fixed the firmware. If you can try it and and let us know if it works, that would be great:

Community Manager

Be sure to click Kudos for those who have helped you.
Select Accept as Solution for posts that have helped to solve your issue(s)!
New Member
New Member

WorkCentre 6515 firmware update fails

Product Name: WorkCentre 6515
Operating System: Windows 11

I am unable to upgrade the firmware on a WorkCentre 6151DN from 65.66.91 to 65.69.51. Using the Windows Firmware Upgrade Utility, with an ethernet cable connected between the printer and router, the firmware appears to transfer fully, but does not let me click on the next button. After 10 minutes or so the utility states "fail to check updating. Please check the device" then  "unknown to update". With a USB cable connected between printer and PC, the firmware does not appear to even transfer. I have changed the setting in the printer to make Ethernet the primary connection and disabled wi-fi, then tried again but that didn't work.

I am unable to use the EWS method to upgrade because in the "Admin>System>Software Update" page I have never had the setting which allows you to select the .bin file. On this page there is only the setting to enable/disable software updates.

While this is happening, the printer is displaying the expected message "An authorized user is making changes to this device, please wait...." When I power off and turn the printer back on, it prints out a software upgrade report "The software upgrade failed(017-759) (Upgrade NG)" then prints out the versions of the various ROMs in 65.66.91

The firmware was upgraded successfully in May 2021 to 65.66.91.









Tags (1)