cancel
Showing results for 
Search instead for 
Did you mean: 
dukatka New Member
New Member

WorkCentre 6655i Firmware downgrade/upgrade failed

Product Name: WorkCentre 6655i
Operating System: Windows 10 x64

Dear Support.

We are still using Safecom-Go which only works with older firmware versions. So I took out nice new 6655i and using altboot USB I downgraded the firmware from 073.110.075.34540 to 072.110.044.20510. Mind you, this 072 version was only available on the WC6655 page and not the 6655i one but we have already similar devices working with 072.

Downgrade finished, device booted up and was loading on the green page (while showing UI software version 072.114.20500) after which it went into a reboot loop. Have browsed through a number of posts detailing the altboot process and its restrictions/requirements.

Have tried again to altboot a few times using different sized USB sticks with most attempts failing with Software Upgrade Error or the device ending up on the green loading page for hours.

Currently I am trying to upgrade back to 073 without much success, get the same behaviour as with previous attemps.

Any assistance would be appreciated. Thank you.

 

0 Kudos
1 Reply
gabiene Advisor
Advisor

Re: WorkCentre 6655i Firmware downgrade/upgrade failed

Hi,

Have you tried AltBoot procedure with FORCED_UPGRADE file inside the AltBoot folder?

 

Gabi

0 Kudos