Showing results for 
Search instead for 
Did you mean: 
Scott_Hu New Member
New Member

Workcenter 4250: Software Upgrade in progress

Workcenter 4250 shows "Software Upgrade in progress" forever, cannot print and/or copy.

We didn't initiate the upgrade, seems it started automatically.

The web interface is still working, but I couldn't initiate another upgrade, got the "Printer is Busy" error.


Is there any way to stop the upgrade and make the machine working properly?

Will a factory reset solve the problem? If so, how to do it?




0 Kudos
2 Replies
Analyst Nation Moderator Joe053204-hcl
Analyst Nation Moderator

Re: Workcenter 4250: Software Upgrade in progress

Unplug it from the LAN to discount any outside source updating it from your LAN.


Make sure there is no USB key plugged into the printer


Attempt to run a Software reset via :Machine Status > Tools > Device Settings > tests and resets > Software reset > System Software reset > Confirm (Should not incur data-loss, but might)


Attempt to Disable updates via CWIS: Properties > Maintenance > Upgrade Management and un-check the box Apply


Change the IP address and attempt to cancel any and all print jobs in queue of any PC/Mac as well as the printer (Job Status screen)


Perform and ODIO (On Demand image Overwrite)

CWIS > Properties > Security > On Demand image Overwrite  >Manual > Full > Start (Nothing of value should be lost)


A full factory reset would require a technician from Xerox, or someone with access to and an understanding of a Xerox 4250 Service Manual, which is not sold obviously.

Please be sure to select "Accept Solution" and or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!

0 Kudos
Scott_Hu New Member
New Member

Re: Workcenter 4250: Software Upgrade in progress

Joe, thanks for your quick responding.


I unplug the network cable, and tried to to press "Machine Status" botton, but didn't get any response, the screen still shows "Software Upgrade in Progress".


Then I tried disabled updates via CWIS, then "On Demand image Overwrite" -> Full, it took a long time to finish, but no luck as well.


Actually I have a service manual at hand, but couldn't figure out how to do a factory reset. I could only find the way to do a memory clear.







0 Kudos