cancel
Showing results for 
Search instead for 
Did you mean: 
abrown31 New Member
New Member

Workcentre 7125 Halts During Startup

I have a Workcentre 7125 that does not complete the startup sequence. It's only 1.5 years old! Still on original toner cartridges.

 

It stops on step 3 of 6 during startup. The scrollbar continues to move and the Xerox logo is displayed against a black screen, but it does not move past this stage.

 

Before it froze, the on-screen menu was moving VERY slowly while it was processing a simple, 1-page document. I decided to reboot it via the power switch on front of the machine. It shut down properly.

 

Upon starting up, it did not get past step 3 of 6 during boot. 

 

No errors. No beeps. Nothing out of the ordinary... I tried to boot without network cable - nothing.

 

Would like to figure out what the problem is.

0 Kudos
4 Replies
Account Deactivated

Re: Workcentre 7125 Halts During Startup

Hello abrown31.

Thank you for using the forum.

I contacted our support team and they feel this might be a hardware issue.  They recommend you power down, unplug and check all the cables, reseating them.  After it is unplugged for 2 minutes try to power it up again.  If it is still not working it is recommended you contact support at 1-800-821-2797.

Please select "Accept Solution" and / or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!
Thanks,
SandyP-Xerox
Moderator
0 Kudos
abrown31 New Member
New Member

Re: Workcentre 7125 Halts During Startup

Thank you for replying to my problem.

 

Since the factory warranty expired 6 months ago, I would like to diagnose this problem on my own without having to pay for tech support. I feel that this unit is still new and it should be still be covered under warranty. Like I said, it is still on the original toner cartridges.

 

Could you please advise me on how to determine what the issue might be? Is there a "diagnostic mode" that I could access to look for fault codes? I cannot access the printer via the network when it is plugged in.

 

Thanks.

0 Kudos
abrown31 New Member
New Member

Re: Workcentre 7125 Halts During Startup

I am happy to report that I was able to fix our Workcentre. I contacted some folks who repair Xerox machines locally and they helped me diagnose it over the phone. Apparently, it's a known firmware issue.

0 Kudos
Account Deactivated

Re: Workcentre 7125 Halts During Startup

Hi abrown31.
Glad to see that you were able to get your issue resolved and you are able to use your Workcentre.
Please select "Accept Solution" and / or select the thumbs up icon to enter Kudos for posts that resolve your issues. Your feedback counts!
Thanks,
SandyP-Xerox
Moderator
0 Kudos