Showing results for 
Search instead for 
Did you mean: 
New Member
New Member

Xerox Phaser 7800 boot loop - Green screen

Product Name: Phaser 7800
Operating System: Windows 10

Hi everyone.
Not so much of a question, more on how I resolved an issue it had (thanks to this forum!)

I recently bought a used Phaser 7800 that worked fine. Wonderful prints. After one week of use we tried to print a small job when we discovered we had the wrong paper inserted, so we cancelled the job using the cancel button. A second later: the text "Shutting down" appeared and the machine shut down. And started again. And shut down again, going into some sort of boot loop. Everytime it started up it only showed a green screen, flashed once and the back into black and repeat.

About now I started to feel the panic rising, what do I do now with this (for me) new machine?!

After some hours of searching the internet I came across this forum and read that firmware updates could be the issue. So I went through the ALTBOOT-procedure with different FW, but nothing.

Then I read about a guy from Perth, Australia, who just replaced the harddrive. I thought I'd go for the harddrive and SD-card replacement and hope for the best.

So I ordered a new 2,5" harddrive and a SD-card with 16Gb memory and I also got a SD-card image from Gabiene (thank you!) to imprint on the card. When I got the parts I formatted the harddrive into NTFS and imprinted the SD-card with the image. Then I just replaced them in the back of the machine.

I then slowly plugged in the power cord, waited 15 seconds, turned on the main power, waited 15 seconds, turned on the second power button and waited...

The green screen appeared as it always had done, but after a few seconds more it went to the next screen, then the machine made some noices and then the main screen appeared with the wonderful text: "Ready to Print"!


This may not be the correct way to resolve this issue. There might have been some easier way so fix this, but don't dispair if you have a problem like this, chances are it might be quite easy to fix! And much thanks to this forum right here.

I hope this post might help someone in the future. In any case, thanks to everyone who has contributed to this forum so far!