Showing results for 
Search instead for 
Did you mean: 
3 Replies

Re: Firmware upgrade 68.66.91 replaced by 67.66.91 and Failed Installation

Jump to solution

Thanks for writing that reply. The pathway is not clear at all - even after I found that flow chart illustration showing what to do to upgrade to 68.66.91 and to use the bridge update if you don't have 68.59.1 or higher, I closed it a dozen times before realizing I could hover my mouse over the update names that appeared on the chart itself, and actually click them to download a file...

Worse though was that at the time I wrote my post, clicking those links (or any other link on the xerox site for the update) took me to the c400 firmware, not the c405. I spent four or five hours troubleshooting this, on a Friday night because we needed to be able to print by Monday morning and xerox was closed for the weekend.

Best part? On that Monday, when they were back to business, someone at xerox must have seen my post because they fixed the links. So the right c405 driver now appears for the c405 links. And then xerox sent me an email effectively saying "hey dufus, you're wrong, those links go to the correct drivers, maybe you should have tried it again." Grrr. The only good part of this experience has been your comment - knowing that my experience helped at least one other person!

Printer works great. Takes a while to warm up to print the first page but after that it's golden. But that initial firmware setup, omg.


0 Kudos
New Member
New Member

Re: Firmware upgrade 68.66.91 replaced by 67.66.91 and Failed Installation

Jump to solution

Thanks so much for posting your experience.  I was in the same boat, having received a C405 with firmware 68.50.61 a few days ago, noticing an error message that printer could not connect to Xerox Remote Services, found nothing on network firewall blocking communication, and found a recommended solution to upgrade to latest firmware, but Xerox Support Drivers and Downloads for C405 didn't show any newer firmware!

It was not obvious that downloads listed in other than the Firmware category, and labelled "Bridge Update" and "Service Pack PL7-R5", were actually the firmware updates I needed!  Using your write-up linking to the 6515 page showing the correct links for the C405 made everything clear.  I was successfully able to install both the 68.59.1 Bridge Update and 68.66.91 Service Pack Update over Ethernet to Port 9100 using the separate Install Utility.  Thanks again for your helpful write-up. Hopefully, Xerox will clean up this confusing naming convention and information which has probably kept many others from discovering this solution.

Re: Firmware upgrade 68.66.91 replaced by 67.66.91 and Failed Installation

Jump to solution

Ok anyone who owns a c405 dn, I have solved this.

Xerox has posted the incorrect c405 driver.

They posted the c400 driver (67.66.91) on the link for the c405 driver (68.66.91).
So you are doomed to FAIL if you,

(a) get the driver from c405 Drivers and Download tab in support for the c405, or

(b) get the driver from the "An Important Firmware Update is Available" banner for the c405 support page, or

(c) follow the instructions on the June 9, 2021 update blog "Important Firmware Updates for VersaLink Printers, WorkCentre 6515 and Phaser 6510".

However if you search around you'll find a Xerox pdf announcing the new firmware here:

Spectacularly, that PDF actually has a link for the correct firmware, which is 68.66.91

No fooling around with certificates or cURL (whatever that is) will be required. Distrubingly the title indicates that the platform is Win7 not Win10 but right now, I'll take what I can get.

And Xerox - really?? Aren't you like a multinational with hundreds or thousands of people working on this stuff?

Next question though - this update came out in June. It's now October. There are no posts on this? Am I the only one who owns a c405??? Maybe everyone is doing automatic updates, which you can't do with the older firmware.  Hopefully this helps someone. 

c405 Firmware upgrade 68.66.91 replaced by 67.66.91 and Failed Installation

Jump to solution
Product Name: VersaLink C405 Color Multifunction Printer
Operating System: Windows 10 x64

I have a c405dn. Just purchased. But it must have been old stock because it had firmware 68.50.61.

The printer can't access the net because it's firmware is too old (a security issue). For my version, Xerox instructs that I must upgrade to bridge firmware 68.59.1 before installing the more secure 68.66.91. Fine, I successfully upgraded to 68.59.1.

However the Xerox link for the new 68.66.91 takes me to firmware 67.66.91. When I install that through the web interface, I get ERROR 016-742 indicating it's the wrong version of firmware to install.  That seems to make sense, I'm installing 67.xx.xx on top of 68.xx.xx.  Maybe Xerox is accidentally providing the wrong firmware version? But if that's the case, why aren't there hundreds of blog posts about this?

I did find an older post saying that I might be successful if I use the Xerox Certificate Remediation utility. But that requires installing Java Runtime and cURL and things I've never heard of before. Because I'm not an IT consultant, just a guy who bought a printer this week.  

Any suggestions would be very welcome. Thanks!


0 Kudos